No GUI response on host PC when installing JetPack 3.1

Have problem in installing JetPack 3.1. Tried to search online and found similar problems, but the solutions offered seems not applicable to my case.

Host machine:
64-bit Windows 10 Pro, Core i5 3.2Ghz, 8GB RAM, 250GB H/D
Enabled Windows Subsystem for Linux
On BASH window, command “lsb_release -a” reports a description of
Ubuntu 16.04.2 LTS
Codename: xenial

Installed Xming X server on the Host Windows

Installed xterm on Ubuntu subsystem
Installed x11-apps on Ubuntu subsystem to verify the GUI is working.

Downloaded JetPack 3.1 and saved JetPack-L4T-3.1-linux-x64.run to a Ubuntu folder.
Open a BASH window, and ran the command
./JetPack-L4T-3.1-linux-x64.run

The system prompted:
Creating directory _installer
Verifying archive integrity… All good.
Uncompressing JetPack 100%

Then nothing else happens.

Under the directory, an executable JetPack_Uninstaller and a directory _installer were created.

Tried to run
JetPack_Uninstaller
But failed with error as well:
error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
127

Does anyone have any suggestions on how to proceed?

The command line requires any x86_64 Linux, Ubuntu 14.04 is required for JetPack (Ubuntu 16.04 should mostly work).

Windows will not work even with compatibility commands…an actual true Linux is required because there are a number of areas where Windows simply will not understand Linux details. One example is that the flash program itself is x86_64 Linux ELF binary…Windows cannot execute this. Another example is that permissions must be preserved…it is not possible to do this on a Windows file system type. Loopback block devices must be used, Windows can’t do that (it’s a Linux device driver…you can’t load Linux drivers into Windows). Device special files must be understand…Windows does not understand that. JetPack requires an X11 graphical interface…Windows does not have that (Cygwin can add this to some degree, but it won’t work with JetPack…libgtk-x11 failure is an indicator of this missing requirement). The list goes on.

Windows cannot be used at all. A VM sometimes works, but even this will fail if not done correctly on a native Linux file system type (the VM difficulty is in getting it adjusted for the situation…a case where practice can be more difficult than theory).

Not to defend the Windows, but I have installed Xming X11 server and run several x11 apps to very the graphical interface works in the Ubuntu subsystem.

Anyway, just want to figure out the minimum requirement of the host machine. TX2 itself is a powerful Linux machine already, which make the hesitancy legitimate when considering to wipe out another 64-bit PC for the purpose of flashing Jetpack for the TX2 target. According to “Key Features in JetPack 3.1” https://developer.nvidia.com/embedded/jetpack and “JetPack 3.1 Release Notes” https://developer.nvidia.com/embedded/jetpack-notes , not much details were given for the requirement of host machine other than saying a 64-bit Ubuntu Desktop.

How about Oracle’s VirtualBox system emulator on Windows 10? I don’t know if VirtualBox is classified as a type of VM. You input would save us a lot of time and effort, please help.

Thanks for the advise.

People have been known to get VirtualBox working. It would be an absolute must that it have a native file system type partition of its own, it won’t work on NTFS. Even so there have been a number of tweaks required in many cases to get USB to behave correctly. The gist is that you have to be certain the recovery mode Jetson is passed through, and often an increase in buffer size. It stands a chance of working; it stands a chance of needing work to get working.

Try first with Ubuntu 14.04 instead of 16.04. 16.04 also needs some adapting.

Thanks linuxdev for the advise. You convinced me of the need to invest more efforts in building a clean Ubuntu ground up.

You may want to run that as sudo.

Separately: Get a low-cost laptop or NUC or similar small box with some crappy CPU and built-in graphics; as long as you have > 100 GB of free disk space so you can generate the disk image without running out of space, you’ll be good.

Separately, I don’t share the opinion that 16.04 requires additional work. I’ve bee running 16.04, and both the JetPack installer, and the command-line flash tools, and the kernel builder, work fine. Most important is to run JetPack installer with sudo before doing anything else IMO.
(I run on some old Core i7-2500 with a 128 GB drive that I had laying around.)

I only mention 16.04 might require work because some people have had comments on sample programs or package installs to the host being slightly different than from 14.04…plus 14.04 is the only one officially supported on host so far (it was stated that a future release would officially support an Ubuntu 16.04 host).

Ah, yeah, I don’t run the samples on the host!