No gui, trying unsuccessfully to install cuda drivers (for use with ollama)

I know it seems like this has been posted before, but I have followed the directions. I think I might know why my situation is different, but maybe someone can help.

$ lspci | grep -i nvidia
01:00.0 VGA compatible controller: NVIDIA Corporation GK208 [GeForce GT 635] (rev a1)

I followed this:

But when I run this:
$ nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I have gone through and purged all nvidia drivers, rebooted and even tried:

I am running Ubuntu 22.04 without a GUI. It is essentially headless.
Is it possible that running without a gui is causing the issue?

Ultimately I am trying to run ollama and get the benefit of the GPU.

Thank you for any assistance you can provide me.

I can’t speak to your driver issues, but your card is Kepler compute capability 3.5.

ollama seems to require a card with a minimum CC of 5.0.

Also, the last version of Cuda Toolkit to support 3.5, was version 11.8.