No I2C connection with ultra sonic sensor and Adafruit Feather M0

Hi @all,

I tried to connect an ultra sonic sensor to my jetson nano via I2C connection.

I followed this tutorial to build up the sensor: Ultrasonic Sensor for the Jetbot - thestrongestlink

The sensor worked fine at the IDE Arduino and give me the right response to the distance. So the next step was to connect the sensor to the jetson but it faild when I tried to run the code.
So I checked with sudo i2cdetect -r -y 1 if some device is detected but without any result.
I already checked the wiring. I have right connection between my pins and my sensor and also voltage at both pins (3&5)

Now I dont know what to do next or where my mistake could be. Does anyone has an idea?

Here is a picture of my wiring. I hope evyerthing is clear to see.

Hi @Trumany
Could you help to comment for this topic.


Hi, have you used an oscilloscope to check the I2C1 signals waveform?

Yes, I also checked the signal of the scl and sda pin when i run i2cdetect. Below you can see both picture.


It looks like the the Feather M0 response to the clock pulse and send back a signal. But there is still no device found.

Is there anything to install before I use I2C? I thought no, isnt it?

I found the problem.

The Feather didnt have a voltage supply, only the ultra sonic gets 5V from the jetson.
So I used a mirco usb cable to power up the Feather M0. Otherwise you can use a pin for voltage supply.
I thought it gets voltage from the ultra sonic sensor.