No Monitor Display for DriveOS 5.2.6.0

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.6.0.8170
other

Host Machine Version
native Ubuntu 18.04
other

I’ve been trying to enable monitor display for a Xavier with DriveOS 5.2.6.0.
The instruction for enable display here, didn’t make it work.

Turning on X server along, the monitor shows “no signal”
Installed gdm3 and ubuntu-unity-desktop, started the gdm3 service with service gdm3 start, the monitor was still black but had some ambient light. It did not show “no signal”, which looked like there was signal to the monitor but it just didn’t display anything.

Is it possible to use monitor for DriveOS 5.2.6? What can be the reason for my problem?

I have no problem. Please try with another monitor or run nvsipl_camera (no need to run “sudo -b X -ac -noreset -nolisten tcp” in advance).

If I plug a camera and run the camera example, the camera video is streamed on the monitor, there is just no desktop or console displayed on the monitor.

Please follow Installing GUI on the Target. Thanks.

That is the instruction I followed to get this point. I tried that on a fresh device still didn’t work. Should we execute those command on USB console right after setting up the accounts? I did that through ssh login.

I haven’t installed ubuntu desktop.
May I know why you need it?

At first I need to test image processing capabilities that are demonstrated in the NvSIPLCamera. But it turned out that we don’t need a desktop to make it work (which I supposed so). However having a desktop means easier access to the board. We can get into it without internet connection or host machine with minicom, which also important when multiple people are working on a Xavier.

Thanks for letting us know.
I believe it’s working on 5.2.6. But I’ll give it a try.

After followed the step 4 and rebooted, I can see the desktop. FYI.

4.To enable autologin, open /etc/gdm3/custom.conf as a superuser using a text editor (vim, gedit, emacs, etc.) and add the lines below to the file:

Enabling automatic login

AutomaticLoginEnable = true
AutomaticLogin = nvidia

1 Like

Hi, @leqiang.wang

Have you sovled this problem? Have you seen GUI?

Yes, I finally got it work by reinstalling gdm3, solve all errors, and hard reboot (power cycle). Thanks for the help!

Good to hear you solved the problem.