No network in DRIVE OS 6.0.5 on DRIVE AGX Orin

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)

Target Operating System

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
other (940-63710-0010-300)

SDK Manager Version

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers

Thank you for letting us know. Can you please provide more details about the issue you’re experiencing? Are you able to see any network interfaces when running ‘ifconfig’ command? Also, may I know if you are using the 10 GbE RJ45 connector (on the right of the rear panel)?

yes, I could see the network interfaces when running ifconfig command. No, I am not using the 10Gbe RJ45 connector. I am using 1Gbe RJ45 connector.

I suggest trying to use the 10 GbE RJ45 connector instead of the 1 GbE RJ45 connector to see if the network works.

I tried by using the 10Gbe RJ45 connector, still there is no network. It seems that networkmanager is not getting installed with the OS, or it might not be running.

Please note that DRIVE OS does not use the standard NetworkManager (mentioned in the document page), so it’s expected that it’s not installed on your system. To diagnose the issue with systemd-networkd, please check the syslog and see if there are any error messages or clues. This should help identify what’s causing the issue with your network connection.

I had tried diagnosing the issue but the it still exits.

I have attached the syslog [there were some errors such as MCU_FOH: ErrReport: ErrorCode-0x28f4 ReporterId-0xe04c Error_Attribute-0x0 Times tamp-0xaed444c]
Syslog.txt (11.2 KB)

I have also attached the systemctl and ifconfig output.

Have you tried using the Ethernet cable with other devices, such as your PC or laptop? Also, the file you provided isn’t the syslog. Please check the syslog for any clues.

yes i had used the Ethernet cable with other devices and it works fine.

From the syslog, it looks like nv_networkd_wait_online.service failed.

Please provide the complete syslog. Also, DRIVE OS 6.0.6 is now available. I encourage you to give it a try.

To make it easier for other developers who may encounter the same issue in the future, please always provide logs in text format instead of screenshots.

I had tried by flashing the DRIVE OS 6.0.6 but still the issue exists.

Please find the syslog file attached.
syslog (808.6 KB)

Thank you for providing the log. Is it from connecting the Ethernet cable to the 10 GbE RJ45 connector? While I review it, I would appreciate if you could clarify some additional information for me. Has the network ever worked with the 10 GbE RJ45 connector on the unit, with any version of DRIVE OS? Also, would you be able to try the same test with a different devkit? What’s the part number of the issue unit?

Yes, the Ethernet cable was connected to 10Gbe RJ45 connector.
No, the network never worked with the any version of DRIVE OS.
As I have got only 1 devkit, it won’t be possible to try with a different devkit.
The part number of the issue unit is : 940-63710-0010-300

1 Like

To eliminate any potential DHCP issues, please follow the steps below and collect the debug information:

  1. Connect the device directly to the host and assign a static IP address.
  2. Ping between the device and the host.
  3. Get the output of “ethtool -S mgbe1_0” on the device side while the host is pinging.
  4. Run “tcpdump -i mgbe1_0” on the device side.

I connected the device and host directly. The ping was successful.
Please find the output of “ethtool -S mgbe1_0” attached:
op.txt (9.1 KB)

Couldn’t run tcpdump on the device side, as tcpdump is not installed on the device side. [couldn’t install it as network is not working]

1 Like

Since network is working with static IP, first copy to /usr/lib on the target machine. Then, you can use the command “./tcpdump” from any path on the target machine to capture the dump. (231.0 KB)
tcpdump (1.1 MB)

To troubleshoot the issue with DHCP, please try capturing the output of “tcpdump -i mgbe1_0” and send it to us for analysis. This will help us identify the root cause of the problem and find a solution.

Please find the output of “tcpdump -i mgbe1_0” attached :
tcpdumpOP.txt (2.0 KB)

output of “ethtool -S mgbe1_0” -
ethtoolOP.txt (8.9 KB)

1 Like

The issue got resolved. It was happening as i was connected on the university network.

1 Like

Thank you for letting us know.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.