No power on Tx2 developer kit.

I have a TX2 developer kit that will not power on at all. I don’t see any LEDs light up, and I don’t have any voltage at the back of the 19V DC jack with any of the power supplies i’ve tried. One of the supplies seemed to reset when plugged in so I’m assuming high current draw?

I measured the resistance from the center pin of the DC jack to the shell of the DC jack and it shows shorted. I’ve started to walk through the power circuit with the diagrams but most of the components are all showing shorted to ground on my meter.

I don’t see anything when I have the micro usb plugged in and run lsusb.

Any help?


When a micro-B USB wire is connected to a host the host would show under lsusb only if the Jetson is powered up under recovery mode…possibly R28.2 might also show up when booted. No power indicator means it can’t be on.

Many people have had issues with power supplies which are not the one shipped with the devel kit…is this one of the supplies you’ve tried? Does it measure any voltage when unplugged (should be a bit over 19V)?