No power to anything? help!

I have been working on my Jetson nano with a coral accelerator all day with no problems. I was installing something with pip and it crashed no mouse, keyboard, numlock, or network traffic. I waited 5 minutes and then power cycled it. It got stuck on the nivida logo for 30 minutes so I power cycled it a second time and now I get nothing. No power to usb no dvi signal no power to nic and no flashing lights just the green light. my power supply is 5.2 volt 4 amp using the barrel jack and jumper.  I also tried it with my pi power supply 5.2v@2.5a

I am not setup to UART into it but I don’t think it would work.

Hi jamesewood87, have you tried re-flashing your SD card? Perhaps a system file got corrupted during the power cycling.

No I did not re-flash but the drive is not corrupted. I can plug it into my workstation and it mounts fine. I don’t want to wipe out all my work it took me the better part of a day to get it inferenceing.

Does it check the SD card before it posts? will a nano power on without an SD?

Without an SD card, you should get a green LED, but without kernel from the SD card it wouldn’t be able to get very far in the boot process.

Next step would recommend would be to check the output from serial UART terminal. You could also backup your existing SD card image to your host PC (see this post), and then re-flash your SD card with the original, vanilla image to see if the issue may be related to corrupted SD card contents.

When a working jetson nano without an sd card is powered on the boot process does turn on the nic and the usb and the hdmi correct?

In my case there is 0 signs of life other than a single solid green led. No usb device ever gets power. The nic never turns on, no signal, no lights, no packets. there is 0 hdmi signal.

I don’t have a UART cable, but I could ask one of our electrical engineers.

I think it’s time for an RMA, or we could just switch to coral.

That is incorrect, because the kernel image is stored on the SD card, and the kernel is what will activate these devices.

It would be useful to see the boot text and what is occurring in the kernel, if it hits some error somewhere. Or as suggested, try another SD card if possible. An additional suggestion is to re-flash the device with SDK Manager tool, which also reflashes the bootloader.

See here for info on the RMA process -
If the unit is defective, we can send you a replacement in advance.