No sdk aviable

Dear all,

got the tx2 today, but it’s with ubuntu 18.
I wanted to downgrade to ubuntu 16.
since I working on Mac, I using parallels for using vm of ubuntu 16.

getting no sdk aviable error, please assist

The L4T releases supporting a Jetson with Ubuntu 16.04 LTS is L4T R28.x. The JetPack releases providing the R28.x series are the JetPack3.x series.

You might need to go to these links, log in, and click the link again, but here are:

Note that JetPack3.3.1 installs L4T R28.3.1. There is available a patch as L4T R28.3.2.

JetPack is a front end to download and install the other software. Once a system is flashed, JetPack can add optional packages (flash itself does not add those optional packages). Normally you would not mix an L4T release and a JetPack release which are not matched, but R28.3.2 is a patch, not a full release, and thus you can flash R28.3.2 on command line if you want to, and then use JetPack3.3.1 to add extra packages (many people do not realize they can uncheck the flash option and not bother with recovery mode). I will recommend if you want to use an old distribution, then install R28.3.2 on command line, followed by adding optional packages via JetPack3.3.1.

L4T itself is just the driver package plus sample rootfs. This is what you use to flash on command line. Basically:

  1. Unpack the driver package without using sudo. This produces a “Linux_for_Tegra/” subdirectory.
  2. cd “Linux_for_Tegra/rootfs”.
  3. Unpack the sample rootfs with sudo.
  4. cd .., which puts you in “Linux_for_Tegra/”.
  5. sudo ./ (which adds NVIDIA hardware accelerated libraries to rootfs).
  6. You are now ready to flash on command line and do not need to repeat the above for further flashes.
  7. Put the TX2 in recovery mode with micro-B USB connected.
  8. Do not use a VM. Run “sudo ./ jetson-tx2 mmcblk0p1”.
  9. You should now be able to log in to the Jetson. When fully booted like this you can use JetPack to install CUDA or extras over ssh.

In the R28.x L4T series the accounts “nvidia” and “ubuntu” are added by default, with name/pass being the same. Be sure to change those immediately if you are not behind a protected firewall/router environment.