No serial console signal after flash

Hello all!

I have been trying to flash a brand new Xavier AGX using Jetpack 4.5.1. (I have also tried with Jetpack 4.6.1)
According to the log the flash is successful, but when i reset the board i get no Serial Console signal.
I tried dmesg --follow while connecting the board and i get nothing.
I attach the flash log in case it’s useful
flash_log.txt (62.5 KB)

What is your method to get this “serial console signal”?

I connect the micro-USB cable to the board (ttyTCU0)
I run dmesg to see if the host gets the device, and i get no output as if the device is not connected.

Are you saying that even ttyTCU0 does not show up?

The serial console should be no matter to the software installed on it. Even when the board is under flash, this port still outputs log. Do you have any other AGX board or ubuntu host that can do the test?

I remember that the host side should see ttyUSBx instead of ttyTCU0.

It doesn’t show up.
I have tried modifying the extlinux.conf to send this kernel arguments loglevel=7 console=ttyTCU0,115200 and it also didn’t work.
If i put the board on Recovery Mode i get a correct connection message with the deviceId and the vendorId

Yes, i have one more that is working. We were thinking of switching the boards to discard any carrier malfunction.

Yes, i was referring to the board side device.


But AGX’s flash port and serial console port are different… are you sure you are using the correct port?
Is this AGX devkit but not some vendor board?


So you are saying that when you put the board into recovery mode, you can see the node on host when connecting to the type C port but not micro usb port?

I’ll try switching the boards and continue on the topic.

It was a hardware issue. When i changed the carrier it worked.
Thank you very much for the support.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.