no sound via HDMI

Does anybody got a solution ? I cannot see HDMI in system setting -> sound -> output

Thanks!

Can you post your aplay -l output here?

Generally, command like this works if you panel has hdmi audio output.

aplay -Dhw:0,7 LMRstereo.wav

If pulseaudio is not able to open the pcm device you may not see the hdmi audio device in gui. try unplugging and pluging.

nvidia@tegra-ubuntu:~$ aplay -l 
**** List of PLAYBACK Hardware Devices ****
card 0: tegrahda [tegra-hda], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: tegrahda [tegra-hda], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 0: ADMAIF1 CIF ADMAIF1-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 1: ADMAIF2 CIF ADMAIF2-1 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 2: ADMAIF3 CIF ADMAIF3-2 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 3: ADMAIF4 CIF ADMAIF4-3 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 4: ADMAIF5 CIF ADMAIF5-4 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 5: ADMAIF6 CIF ADMAIF6-5 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 6: ADMAIF7 CIF ADMAIF7-6 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 7: ADMAIF8 CIF ADMAIF8-7 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 8: ADMAIF9 CIF ADMAIF9-8 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 9: ADMAIF10 CIF ADMAIF10-9 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 10: ADMAIF11 CIF ADMAIF11-10 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 11: ADMAIF12 CIF ADMAIF12-11 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 12: ADMAIF13 CIF ADMAIF13-12 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 13: ADMAIF14 CIF ADMAIF14-13 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 14: ADMAIF15 CIF ADMAIF15-14 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 15: ADMAIF16 CIF ADMAIF16-15 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 16: ADMAIF17 CIF ADMAIF17-16 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 17: ADMAIF18 CIF ADMAIF18-17 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 18: ADMAIF19 CIF ADMAIF19-18 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 19: ADMAIF20 CIF ADMAIF20-19 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 60: ADSP PCM1 ADSP-FE1-60 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: tegrasndt186ref [tegra-snd-t186ref-mobile-rt565x], device 61: ADSP PCM2 ADSP-FE2-61 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

My system setting panel does not have hdmi audio output option.

Hi Zhengchun,

Please try below command:
export DISPLAY=:0 pactl load-module module-alsa-sink device=hw:0,7

Then the tegra-hda option will show up in system setting -> sound -> output

@Zhengchun - I had the same problem and followed your instructions. I now have HDMI audio. Thank you.

@Zhengchun
I spoke too soon. The above solution works for the current session, but once I reboot the machine and log back in, I no longer have audio.

What must be done to make the changes you’ve suggested work permanently?

I was able to find a solution by following the explanation https://wiki.archlinux.org/index.php/PulseAudio/Examples.

At this point:
Manually configuring PulseAudio to detect the Nvidia HDMI

but I modified /etc/pulse/default.pa using the line below:
load-module module-alsa-sink device=hw:0,7

I hope this gets fixed for 17.2.
Audio over HDMI worked out of the box for me with the preflashed 27.0.1 but then failed with 27.1 with the same set up.

Hi,
For a quick fix please apply
load-module module-alsa-sink device=hw:tegrahda,7
into
/etc/pulse/default.pa.hdmi

We will have this fixed in next release.

Thank you,

I assume we can simply replace the former load-module like this:

#load-module module-alsa-sink device=hw:Tegra,3
load-module module-alsa-sink device=hw:tegrahda,7

Cheers,
Martin

@DaneLLL, @enthusi, @carolyuu, @LLL74 etc. thanks for your replies. I have not got a chance to try, I will come back once I tried. Thanks again.

okay

I did this and it doesn’t work on my TX2. I still can’t see an HDMI output in the sound settings.

load-module module-alsa-sink device=hw:tegrahda,7
into
/etc/pulse/default.pa.hdmi

Works well! Seems that video player comes with OS cannot support hardware acceleration. I tried to play a 4K video, cpu usage is very high and GPU is very low. The same for Chrome browser when playing youtube videos.

Thanks for sharing the solution!
It works until reboot.
I have tried to add:
crontab -e
@reboot pactl load-module module-alsa-sink device=hw:0,7
and
@reboot /home/nvidia/h.sh

where
h.sh content was

pactl load-module module-alsa-sink device=hw:0,7

but it won’t work.
After I have added it to “/etc/pulse/default.pa”
and added the #!/bin/sh to the h.sh file
it appeared but the analog device got listed twice in the settings->sound
But when I added it to /etc/pulse/default.pa.hdmi - it was of no impact.
Now deleted the crontab entry and edited /etc/pulse/default.pa.hdmi removing the second entry, and it works now, finally
Thanks

Thank you this is work for my jetson …

1 Like

so I am on tx2-4g r32.3.1 and hdmi is not showing up in setting->sounds->output.

when is this going to be fixed?
Terry