no support for OpenMP 3.1?

The latest version of the community edition (17.4) shows a value of 200805 for the _OPENMP preprocessor variable, suggesting that these compilers do not support OpenMP 3.1 (a value of 201107 should appear for 3.1, as is my understanding).

Is this a bug? or is OpenMP 3.1 not supported?

this is set in x86rc as:

set(MPDEFCPP=-D_OPENMP=200805)

The OpenMP version PGI supports is 3.1. This means the value for
_OPENMP is wrong. I have filed TPR 24276 to correct it.

dave

thank you

TPR 24276 has been fixed in the 17.5 release.

thanks,
dave