No video after switching VT or closing X

I’m trying to set up Linux on a new computer and I am having trouble with the nvidia graphics driver.

After switching Virtual Terminals away from X or closing down X the screen goes black and the monitor complains about no signal.

I’ve tried everything I can think of.

Booting both UEFI with simplefb and CSM with a text mode console.
Different versions of xorg-server.
The previous major version of the nvidia display drivers. (Anything earlier doesn’t support my 1660ti).

And google has not turned up anything helpful.

The sticky said to include nvidia-bug-report.log.gz but I don’t see a file upload.

nvidia-bug-report.log.gz (1.05 MB)

Hmm, strange. Does it work if you use the efifb framebuffer driver rather than simplefb?

I’ve not been able to get efifb to work at all.

I’ve just worked out why efifb was not working. I had CONFIG_X86_SYSFB set in the kernel.

Same thing happens with efifb.

I managed to get it working.
What I did was use the old kernel I had been using before.
The kernel I could not get working was a 4.19.
While the one I had been using was a 3.18.
I had not intentionally configured them differently.
Nothing that I’ve not also done with a new compile of 3.18.140 without a problem.
Right now I’m just happy to have something that works so I’m going to try and get a newer kernel work anytime soon.