No video output via HDMI


I have a problem with the Jetson AGX Xavier. There is no video output via HDMI. I can receive a signal via a USB Type-C to HDMI converter, but there is no output on the HDMI port. I’ve already tried two monitors.

I’ve attached the dmesg output, in case it gives more information.

Thank you

dmesg.txt (74.3 KB)


  1. Is it a xavier devkit?
  2. Do you mean you could convert the DP signal from typeC to your HDMI monitor but when it is using native HDMI port, it is not working?

Actually, I see the display is programming into 297000k hz which is 4k mode. No other error is seen.

[   60.545879] Parent Clock set for DC plld3
[   60.550412] tegradc 15200000.nvdisplay: hdmi: tmds rate:297000K prod-setting:prod_c_hdmi_223m_300m
[   60.552018] tegradc 15200000.nvdisplay: hdmi: get RGB quant from EDID.
[   60.552026] tegradc 15200000.nvdisplay: hdmi: get YCC quant from EDID.
[   60.588408] extcon-disp-state external-connection:disp-state: cable 48 state 1
[   60.588412] Extcon AUX2(HDMI) enable
[   60.588495] tegradc 15200000.nvdisplay: unblank
[   60.588511] tegradc 15210000.nvdisplay: blank - powerdown
[   60.588524] tegradc 15220000.nvdisplay: blank - powerdown

Thank you for your time.

Yes, it is a devkit.

Yes, it works with a Type C to HDMI converter.

So there is no error on the softwareside detected?


Yes, according to the kernel, there is no error.

You’ve hotplugged this monitor once in this dmesg, right?

Do you have other native HDMI monitor to test this port?

Kind of, it is a graphical drawing board, which also has HDMI input functionality, I had to enable the input mode again, because the monitor went out of input mode, because there was no signal.

I’ve already tested it on another monitor, and I’ve attached the dsmeg from that one now too.dmesg2.txt (71.0 KB)


I’ve already tested it on another monitor, and I’ve attached the dsmeg from that one now too.dmesg2.txt (71.0 KB)

Then how about the result of second monitor? I guess it is working, right?

Actually, the log is totally same in display but just becomes 1080p mode.

No, I don’t get a signal. If I connect two at the same time, one via HDMI and one via Type C I can see it on the Type C monitor and set everything, but I have no image at the hdmi one.


Just want to confirm, that 2nd monitor is a native HDMI TV/monitor, right?

To prevent it is hardware issue…

  1. Do you have only one xavier to do the test? If you have other xavier, could you try that monitor to another xavier to do the test?

  2. If there is no other xavier, do you have other HDMI TV/monitors in your office/home that can try? It should be at least one of them could work. We have 6~7 monitors in office and they all work fine with my xavier.

Yes, it is.

I also tried it with adapters on other monitors…
But I think that if you can rule out a software issue, it probably is a hardware issue…


Why do you have to use adapters? None of them have a native HDMI port?

Some of our monitors don’t have native HDMI input. But I’ve tried it now on all native hdmi monitors in our office and used two different cables. Still I have no image output.

Ok, then I guess probably a hardware issue. Please file RMA for this device.