No video signal and no TTY after driver installation on elementary OS 5.0, Ubuntu 19.04 and 19.10

I’ve been unable to make one of my PC graphics card work with Ubuntu 19.04, 19.10 and elementary OS 5.0 (18.04 based) since I first tried in April.

The card is a GTX 1660 and whenever I install NVIDIA 435 or 440 drivers (whether from the official repo, the ppa or using the .run from NVIDIA’s website), I get a black screen, the monitor keeps shutting on and off (no signal) and I can only ssh into the machine. Modeset does not solve it for me and I also can’t make into a TTY. In the Windows partition 10 it works perfectly, and before I install the NVIDIA drivers in elementary or Ubuntu 19.04 all I get is a very poor resolution like that in secure graphics mode. In Ubuntu 19.10, as drivers are installed during the system installation, I already start with a black screen.

Usually, the nvidia-smi command gives a driver error, but I’ve just formatted and fresh-installed again today to try for the thousandth time with the 435 driver from the official repo (not the ppa), and at least I get a nvidia-smi response with everything seeming ok. But still, no signal. Any recommendations? Blacklist nouveau (I had already tried that before)?

I’ve also found that I can set the BIOS setting Initial display output to IGFX instead of PCIE 1 (it’s a Gigabyte motherboard), plug the HDMI cable to the motherboard’s video output instead of the Nvidia gpu one, and then I can get to the desktop.
Awkwardly for me, everything seems to indicate the NVIDIA GPU is in use (is that even possible connected to the integrated gpu?). The gears tests make the GPU usage jump to 100% in the NVIDIA settings app. Despite of this, if I instead boot Windows, the NVIDIA app says I’m not connected to an NVIDIA card.

It’s been a lot of months waiting for better support for these quite new cards (or so I thought), and I’m starting to get desperate. The machine status now is:

  • An updated elementary OS 5.0 partition with driver 435
  • An updated Ubuntu 19.10 5.0 partitio with driver 435
  • An updated Windows 10 partition.
    Xorg.0.log (28.1 KB)
    nvidia-bug-report.log.gz (1.06 MB)

According to the log, everything seems fine. Maybe the driver is just setting an incompatible mode, did you ever try to connect a different monitor?

Thank you for your great suggestion. You just saved my sanity! I’ve just tried with another monitor and…voilà. But it isn’t the monitor thank god… it’s the motherfucking HDMI cable. For some reason (if you have any idea please enlighten me) I was using a quite long HDMI cable that seems to work great on Windows, and on Linux on other pcs, but not in this one. Why? I don’t have a clue.

Thank you so much generix!

From my observations, the Windows driver uses very a relaxed approach (nowadays, used to be the same) when it comes to edge situations in which the linux driver refuses to work because out-of-standard values. Meaning, the windows driver is more likely to work on broken hardware. Or just fails later.