Not a 10G Marvell Firmware issue

Hi,

This is not a Marvell Firmware issue, I tried all 16 Marvell Firmware fusing but the result was the same.

Not sure what you mean, please provide more information of your issues.
Thanks

Question for 10G (MGBE) Not working - Jetson & Embedded Systems / Jetson AGX Orin - NVIDIA Developer Forums

Please continue updating at the original topic, not open a new one with no details. Thanks

3 times I requested, but the limit request is 3

The reason I am asking NVIDIA about the issue through this forum is because I have not been able to resolve it even though I have tried to resolve it through multiple trials and time (approximately 3 months). It appears that there is no Forum content that says a similar issue has been resolved, and the response from NVIDIA is not clear.

Does your device ever validate on any Jetpack release before?
I mean whether rel-35 ever tested this ?

aqr107_wait_reset_complete only calls phy_read_mmd_poll_timeout. If the PHY didn’t give out any response, then it means this condition does not meet as mentioned in document.

  • Make sure that the PHY comes out of reset and is in a ready state (read the PHY ID by using mdio tool to ensure that the PHY firmware is successfully loaded) when the PHY reset GPIO is toggled.

I can read PHY ID: “31C3 1C12” through MDIO
I can’t read AQR Firmware ID accurately.
-------- Firmware ID is always read as 00, but since this value is incorrect, Error Return (-110)

But you said


So, I tried Marvell all Firmware flashing again, but nothing.

Is this really the issue I need to check with Marvell like you said?

What is the firmware ID got printed from your side now?

If the firmware ID is always a invalid one, it means the firmware is not yet loaded.

  1. Firmware ID Read as “00” always
    Checked by inserting debugging Message for Firmware ID Read

  2. Firmware Loading


    → FW loading H/W signal can be captured with Oscilloscope.

Hi, WayneWWW,

I can now Load EEPROM Firmware successfully.
The problem was that the EEPROM garbage data was not cleared and malfunctioned for reading Firmware ID from AQR Memory.
So, my behavior is to erase the Full EEPROM area and flash EEPROM (firmware) again and the orin CPU successfully can read the exact Firmware ID from AQR Memory.

Another Hardware Question:
The ethernet line is not working now.
The difference between the Dev. Kit and my custom Carrier board is RJ45 connector model name.
The Dev. kit uses AC7416-0011-001HH (Wieson Technologies), but I use JTH-0024NL (PULSE).
Please advise me of the problem that can happen with the Hardware connection.
The below diagram is the two usage different circuit diagrams.

Regards,
netkerl.

Please file a new topic. Looks not related.