Not Able to Add connection for a remote server to the Omniverse Apps

Hi Everyone,
I have set up the Enterprise Nucleus Server on a particular domain name with SSL. Now when I want to add a connection to the various Omniverse Client Apps like Create, View, Audio2Face, etc. Then I am facing the issue of Connection Refused. Try Reconnecting on the App interface and in the browser, it says Successfully Connected. You can use it in the App now. I was facing this issue for the latest versions of Apps i.e.:

  • Create: 2021.3.8

  • View: 2021.3.10

  • Audio2Face: 2021.3.3

  • Nucleus Stack: 2021.3.2

But when I tried adding a connection to the version prior to the latest version, I was successfully able to add the connection and do the operations on it from these apps.
It would be of great help, helping me workaround on this issue.
Thanks in Advance.

Hello @jimit-modi! Appreciate you reaching out to us! I notified the team to help you out! We should hear back shortly!

1 Like

hello @jimit-modi -
I want to make sure i understand your problem.

  1. you had a working Enterprise Nucleus setup and running (no SSL). All apps like Create can connect to this and worked ok
  2. Then you upgraded that same Nucleus server to activate SSL. You did not change the data location in the .env file
  3. During this upgrade to SSL, you did not change versions of Create, correct?

Create version 2121.3.8 will now ask you to login in at browser and that seems to work, but Create itself will state “Connection Refused”. But prior to SSL all was good

hello @jimit-modi -
Can you try this for Create.

  1. Clear you browser cache/cookies
  2. get a command prompt at C:\Users\YOURUSERNAME\AppData\Local\ov\pkg\create-2021.3.8

At prompt type
omni.create.bat --reset-user

Try to connect to the new SSL based server

Hi @mirice, I appreciate that you replied. But you interpreted my query totally in a different way. I would try once again to explain it:

  • I have the Enterprise Nucleus server up and running with SSL.
  • Then I was trying to Add connection in the Create App (version 2021.3.7). Here I was able to add the connection successfully.
  • Now I installed the latest version of Create App i.e. 2021.3.8. Here, the same connection was showing an error stating Unable to connect to the server. Please Try Reconnecting.
  • So, I tried adding the new connection, So as expected I was prompted to enter the credentials in the browser. And after entering the credentials it showed these things as mentioned in the Screenshot on the browser and Create app respectively.

  • So, Now I again tried adding connection in the previous version of Create App i.e. 2021.3.7. And there again it worked well and was able to add connection successfully.

Also, this is the same scenario for View App and Audio2Face App. Getting the same issue in the latest version of the Apps, but not facing any issue in the 1 version prior to the latest one.
I hope that this time I was clear to you in explaining the whole scenario.

Hi @mirice. I tried doing this,but still facing the same issue as mentioned in this comment.

This issue can occur with versions of Create post 2021.3. The issue is that the Nucleus SSL setup (on the docker containers) needs to specify the fullchain.pem as the certificate (not the final pem). You made this change and now you can connect.

Thank You @mirice for your continuous support on resolving this issue. You have been really helpful.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.