Not able to connect to internet from my new jetson nano

Hi all. I just bought an nvidia jetson nano and flashed the image and booted it up. i got a normal ethernet cable and connected my laptop to the jetson. i am not even able to do apt-get update. so itried to look into the forums and tried a few thigns but did not work. i have got my edimax plugged in but the dks installation doesnt work due to dkms not being found. i do not have an option of connecting it to the router as its downstairs, so either i need to get it from laptop or edimax.
also the edimax bluetooth shows up as working, but cannot maintain internet connection though. please help me guide me to see if the jetson is ok or not.

I dont even see wlan0 on the ifconfig. also i tried to connect jetson to router without the display of course, but the ethernet port had one solid green and another amber light blinking al lthe time.


We don’t enable bridging on Nano so it cannot leverage the network on your laptop.

Also, I am not sure if edimax needs extra wifi driver or not. Please check the vendor site to see what driver is needed for it.

I see. I am going to try again :). Thanks