Not able to control Franka Panda using Moveit in Isaac Sim 2022.1.1

I am trying to execute the Moveit Motion Planning Framework tutorial. In doing so, I have downloaded pre-built panda-moveit-config package and am able to run moveit. Following execution launch file is used:

roslaunch isaac_moveit franka_isaac_execution.launch

The Rviz open and successful performs the planning. However, the execution fails every time with the following critical errors:

[ERROR] [1671707006.275505103, 52.666669413]: Unable to identify any set of controllers that can actuate the specified joints: [ panda_joint1 panda_joint2 panda_joint3 panda_joint4 panda_joint5 panda_joint6 panda_joint7 ]
[ERROR] [1671707006.275522091, 52.666669413]: Known controllers and their joints:
[ERROR] [1671707006.275537972, 52.666669413]: Apparently trajectory initialization failed

The panda-config-moveit file package is unaltered and the tutorial is followed without any change. Please help with the solution as I have tried every possible way to solve it.

@deveshkumar21398 , are you seeing this error on the latest Isaac Sim 2022.2.0 release as well?

Hi @rthaker, I haven’t tried it on 2022.2.0 release. However, the issue is finally resolved. I used semu.robotics.ros_bridge extension to configure joint trajectory controller in Omnigraph.

Besides, a quick question - does 2022.2.0 release addresses effort joint trajectory controllers in common ros_bridge extension itself or it is required to add semu extensions?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.