Not able to install Pytorch on Jetson Nano


I am trying to install Pytorch version 1.3.0 on Jetson Nano. It is giving the below error.

nvlink error : entry function ‘_Z32ncclAllReduceTreeLLKernel_sum_i88ncclColl’ with max regcount of 80 calls function ‘_Z29ncclReduceScatterRing_max_f64P14CollectiveArgs’ with regcount of 96
nvlink error : entry function ‘_Z32ncclAllReduceRingLLKernel_sum_i88ncclColl’ with max regcount of 80 calls function ‘_Z29ncclReduceScatterRing_max_f64P14CollectiveArgs’ with regcount of 96
[ 37%] Built target gen_onnx_proto
[ 37%] Built target sleefpurec_scalar
[ 37%] Built target sleefdetpurecfma_scalar
[ 37%] Built target sleefpurecfma_scalar
[ 37%] Built target sleefdetadvsimd
Makefile:68: recipe for target ‘/home/jetbot/pytorch/build/nccl/obj/collectives/device/devlink.o’ failed
make[5]: *** [/home/jetbot/pytorch/build/nccl/obj/collectives/device/devlink.o] Error 255
Makefile:49: recipe for target ‘/home/jetbot/pytorch/build/nccl/obj/collectives/device/colldevice.a’ failed
make[4]: *** [/home/jetbot/pytorch/build/nccl/obj/collectives/device/colldevice.a] Error 2
Makefile:25: recipe for target ‘’ failed
make[3]: *** [] Error 2
[ 37%] Built target sleefadvsimd
CMakeFiles/nccl_external.dir/build.make:110: recipe for target ‘nccl_external-prefix/src/nccl_external-stamp/nccl_external-build’ failed
make[2]: *** [nccl_external-prefix/src/nccl_external-stamp/nccl_external-build] Error 2
CMakeFiles/Makefile2:67: recipe for target ‘CMakeFiles/nccl_external.dir/all’ failed
make[1]: *** [CMakeFiles/nccl_external.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs…
[ 37%] Built target sleefdetadvsimdnofma
[ 37%] Built target sleefadvsimdnofma
Makefile:140: recipe for target ‘all’ failed
make: *** [all] Error 2
Traceback (most recent call last):
File “”, line 756, in
File “”, line 324, in build_deps
File “/home/jetbot/pytorch/tools/”, line 59, in build_caffe2
File “/home/jetbot/pytorch/tools/setup_helpers/”, line 334, in build, my_env)
File “/home/jetbot/pytorch/tools/setup_helpers/”, line 142, in run
check_call(command, cwd=self.build_dir, env=env)
File “/usr/lib/python3.6/”, line 311, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘cmake’, ‘–build’, ‘.’, ‘–target’, ‘install’, ‘–config’, ‘Release’, ‘–’, ‘-j’, ‘4’]’ returned non-zero exit status 2.

Jetson 4.3 sdk version SDcard image is mounted on the device.

jetbot@jetbot-desktop:~$ cat /etc/nv_tegra_release

R32 (release), REVISION: 3.1, GCID: 18186506, BOARD: t210ref, EABI: aarch64, DATE: Tue Dec 10 06:58:34 UTC 2019

I have also tried installing pytorch using the below commands, but it gave error telling it is not supported on this platform.

wget -O torch-1.3.0-cp36-cp36m-linux_aarch64.whl
pip3 install numpy torch-1.3.0-cp36-cp36m-linux_aarch64.whl

I have also tried installing version 1.1.0 and 1.2.0 , but getting same error.


Hi Shankhar, you need to disable PyTorch attempting to use NCCL before building PyTorch (see ‘Set Build Options’ from this post)

$ export USE_NCCL=0
$ export TORCH_CUDA_ARCH_LIST="5.3;6.2;7.2"

What is your version of pip3 that is being reported?

Hi dusty_nv,

I had tried with these build options before, and again I tried now.
But getting the same errors.

And the pip3 version is 9.0.1,

jetbot@jetbot-desktop:~/pytorch$ pip3 --version
pip 9.0.1 from /usr/lib/python3/dist-packages (python 3.6)


The issue got resolved after using the below command,
sudo pip3 install numpy torch-1.3.0-cp36-cp36m-linux_aarch64.whl --user

instead of
pip3 install numpy torch-1.3.0-cp36-cp36m-linux_aarch64.whl

sudo and --user was required.

Thank you.

I see, thank you for providing the modified command that worked in your case.