Not able to install Visual Studio Code on nano boot image (Ubuntu 18.04)

I have a need to run .NET core on my nano and I am able to run C# code successfully. Eclipse is way too flaky and constantly refusing to launch after making simple modifications. I would like to edit the C# code using Visual Studio Code, but I’m getting the following install errors (see logs below). Anyone able to successfully install/run VS Code on Nvidia’s developer boot image of Ubuntu 18.04 for Jetson Nano?

The following packages have unmet dependencies:
code:amd64 : Depends: libasound2:amd64 (>= 1.0.16) but it is not installable
Depends: libatk-bridge2.0-0:amd64 (>= 2.5.3) but it is not installable
Depends: libatk1.0-0:amd64 (>= 2.2.0) but it is not installable
Depends: libatspi2.0-0:amd64 (>= 2.9.90) but it is not installable
Depends: libc6:amd64 (>= 2.14) but it is not installable
Depends: libc6:amd64 (>= 2.17) but it is not installable
Depends: libc6:amd64 (>= 2.2.5) but it is not installable
Depends: libcairo2:amd64 (>= 1.6.0) but it is not installable
Depends: libcups2:amd64 (>= 1.6.0) but it is not installable
Depends: libcurl3-gnutls:amd64 but it is not installable or
libcurl3-nss:amd64 but it is not installable or
libcurl4:amd64 but it is not installable or
libcurl3:amd64 but it is not installable
Depends: libdbus-1-3:amd64 (>= 1.5.12) but it is not installable
Depends: libdrm2:amd64 (>= 2.4.38) but it is not installable
Depends: libexpat1:amd64 (>= 2.0.1) but it is not installable
Depends: libgbm1:amd64 (>= 8.1~0) but it is not installable
Depends: libglib2.0-0:amd64 (>= 2.16.0) but it is not installable
Depends: libglib2.0-0:amd64 (>= 2.39.4) but it is not installable
Depends: libgtk-3-0:amd64 (>= 3.9.10) but it is not installable
Depends: libgtk-3-0:amd64 (>= 3.9.10) but it is not installable or
libgtk-4-1:amd64 but it is not installable
Depends: libnspr4:amd64 (>= 2:4.9-2~) but it is not installable
Depends: libnss3:amd64 (>= 2:3.22) but it is not installable
Depends: libnss3:amd64 (>= 3.26) but it is not installable
Depends: libpango-1.0-0:amd64 (>= 1.14.0) but it is not installable
Depends: libsecret-1-0:amd64 (>= 0.18) but it is not installable
Depends: libx11-6:amd64 but it is not installable
Depends: libx11-6:amd64 (>= 2:1.4.99.1) but it is not installable
Depends: libxcb1:amd64 (>= 1.9.2) but it is not installable
Depends: libxcomposite1:amd64 (>= 1:0.4.4-1) but it is not installable
Depends: libxdamage1:amd64 (>= 1:1.1) but it is not installable
Depends: libxext6:amd64 but it is not installable
Depends: libxfixes3:amd64 but it is not installable
Depends: libxkbcommon0:amd64 (>= 0.4.1) but it is not installable
Depends: libxkbfile1:amd64 but it is not installable
Depends: libxrandr2:amd64 but it is not installable
Recommends: libvulkan1:amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.

Hi,
It is confirmed working on Xavier NX. Please refer to
Jetson Xavier NX FAQ

Q: VS Code is not working on Xavier NX

And try it on Jetson Nano.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.