Not able to run deepstream application as a systemd service

Yes, did set env variable GST_DEBUG=5

Any findinds from the log?

No as updated previously, I could see additional logs (mentioning FPS) without OSD when the pipeline runs correctly. But when the pipeline stops, could not see any additional logs from what was observed (in the first message of this thread).


I even tried removing OSD from pipeline, this also dosnt work and stops the same way.

Please confirm this case. and specify more details the pipeline.

Hi Amycao,

There is confusion since you mixed up 2 comments from 2 different messages.

This thread was started because I had problem with pipeline failing if application was run as a service with OSD enabled. You suggestion earlier was to skip tiler and OSD and directly connect inference output to sink (fakesink) and this worked, I was able to run my application as a service on bootup without any problem except for OSD was not available.Here is that working pipeline for your reference
gst_element_link_many (streammux, queue1, pgie, sink, NULL) //This pipeline works if app is a systemd service

After that I wanted to check how to enable OSD (while running app as a systemd service), as that will be required for troubleshooting live system for any inference related problems (please check messages starting from Sep 27). As you have asked to enable logs, I did that. I could see some additional logs when I tried to run application with OSD enabled normally (not as a service) to confirm that gstreamer logs are enabled and that looks ok as I could see some additional logs. But when run as a service, pipeline fails and I could not see any additional logs.
Hope this clarifies.

Do you have any pipeline modification suggestions to have OSD enabled with application running as a systemd service?


The demo app depends on many other modules, you should make sure the cuda, tensorRT, codec etc… modules start well before the deepstream demo runs in your system. Cause it runs well in the console, so the root cause may be the order of the modules which are started. You need to ensure the order in which services are started.

I also tried to stop and re-start or start the service after complete system bootup. It doesn’t work as a service when OSD is enabled while the same app works independently in a shell with OSD enabled.
Please try this with sample app 3 that is distributed with Deepstream library.


There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one.

Ok, Could you attach the log first? You can add the GST_DEBUG=3 before start your service.
You can also attach your detailed steps to repo this problem. Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.