Not able to run deepstream-test1-app

Hi,

I’m new to deepstream and attemping to run the sample apps. When I try to run the deepstream-test1-app, I just see it is stuck at “Running…” with no output. I ran it with the command

./deepstream-test1-app …/…/…/…/samples/streams/sample_720p.h264
(Also tried with mp4 input)

Based on comments in the other threads, I have tried to collect some diagnostics;

My system:
Ubuntu 18.04
GeForce 940MX
Driver: 430.50
CUDA 10.1
cuDNN 7.6.5
TensorRT 6.0.1.5
DeepStream SDK 4.0.2

  1. GST log for deepstream-test1-app (no output, stuck on “Running…”)
  2. GST log for deepstream-app with the config file source30_1080p_dec_infer-resnet_tiled_display_int8.txt (black screen)
  3. Same as above but with [primary gie] enable=0 (black screen)
  4. Output of gst-inspect-1.0 nvv4l2decoder

However, I am able to run and see output for two other apps with mjpeg inputs;
deepstream-segmentation-app and deepstream-image-decode-app

Please help to get this running… thank you.

deepstream-segmentation-app, deepstream-image-decode-app, test1 sample all use eglglessink for output to display, if with deepstream-segmentation-app, deepstream-image-decode-app you can see output on display, test1 sample should work, not sure where goes wrong, could you please add GST_DEBUG=5 when you run test1 and share the log here?

Oh, see your log, will check.

Check this,


GeForce 940MX not in NVDEC list.

Hi Amy,

Thanks for your response.
I guess I have to search for some cloud solution while this lockdown is on :(