Not able to run sample code

I am running sample code

System Configuration

Tesla P4
Ubuntu 16.04
Cuda 9.2
OpenCV 3.4.0
Nvdia Driver 396.37

I have run following commands

  1. %env LD_LIBRARY_PATH=/usr/local/nvidia/lib:/usr/local/nvidia/lib64:/usr/local/opencv-3.4.0/lib

  2. !tar -xvpf Downloads/DeepStream_Release/binaries.tbz2 -C /

  3. %%bash

make -C Downloads/DeepStream_Release/sources/apps/deepstream-test1 clean
make -C Downloads/DeepStream_Release/sources/apps/deepstream-test2 clean

make -C Downloads/DeepStream_Release/sources/libs/nvparsebbox clean
make -C Downloads/DeepStream_Release/sources/gst-plugins/gst-dsexample clean

  1. !rm -rf $HOME/.cache/gstreamer-1.0/

  2. !make -C Downloads/DeepStream_Release/sources/apps/deepstream-test1/

Till this steps output looks good to me
After this when I run below command it go stuck nothing is happening

  1. !cd Downloads/DeepStream_Release/sources/apps/deepstream-test1 &&
    ./deepstream-test1-app …/…/…/samples/streams/sample_720p.h264ow playing:

please suggest something

It is usually difficult to launch system applications with a GUI through iPython. Have you tried launching from the bash terminal?


It looks like the DeepStream pipeline is executed successfully.
Do you have a monitor connected to the P4 server?


@Aasta Yes, I have a monitor attached with the workstation having Tesla P4

@adeoit I have tried to launch from the bash terminal as well. It stuck at the same point. I am attaching bash screenshot.

It’s working on a local monitor attached to the workstation. But not on the desktop via ssh.


It requires natively monitor to display.

You could try setting up VirtualGL. We have had success with remote displays using that.

@adroit Can you please direct me to any documentation for VirtualGL.