Not able to see any process running at port 2050

Hello,

I followed the steps in the readme.pdf (all went through without any error) and when I try to run the example 1:

./scripts/exec-workflow.sh --workflow 1 --name wf1 --input test-data/ct-abdominal-study-1/ --roi 88,440,53,465,61,142

I see the output:

Output beging:
Parameters:
Workflow … 1
Input Directory … test-data/ct-abdominal-study-1/
Name … wf1
ROI … 88,440,53,465,61,142
Incremental Save … none
Iterations … 200
Sino filename… sino2d.npy
Info filename… info.json
Recon filename… recon

2019-02-22 04:09:24 [INFO]: Copying input dataset from test-data/ct-abdominal-study-1/ to /nv-clara/recon/input/wf1/…
‘test-data/ct-abdominal-study-1//info.json’ -> ‘/nv-clara/recon/input/wf1/info.json’
‘test-data/ct-abdominal-study-1//sino2d.npy’ -> ‘/nv-clara/recon/input/wf1/sino2d.npy’
2019-02-22 04:09:24 [INFO]: Input dataset copied successfully
2019-02-22 04:09:24 [INFO]: Submitting workflow request to http://localhost:5001/recons ‘workflow=1&name=wf1&source=/app/in/wf1&dest=/app/ai/wf1&roi=88,440,53,465,61,142&incsave=none&iterations=200&sinofile=sino2d.npy&infofile=info.json&reconfile=recon’

{“status”: “queued”, “id”: “recon2”, “name”: “wf1”}

2019-02-22 04:09:24 [INFO]: Workflow request submitted, please check output for status
2019-02-22 04:09:24 [INFO]: Please navigate to http://localhost:2050
Output end

Now when I try going to localhost:2050 there is no process running at 2050. When I try to run: telnet localhost 2050, I am not able to.

So I am not sure what is going on? why I cannot see the example running? Is there a way to look at logs/debug messages to trace the error.

OS Version: I am using debian 9.8.

So I tried to debug and found that Render Server is not running and when I run docker-compose up I see following error:

renderserver_1 | ./RenderServer: error while loading shared libraries: /usr/lib/x86_64-linux-gnu/libcuda.so.1: file too short
scripts_trtis_1 exited with code 127
scripts_renderserver_1 exited with code 127

Can anyone confirm that they are able to run Render Server?

Also are there any pointers to debug this?

I ran the workflow and it seems to be working fine, I would suggest you deleting the Docker image you are using and rebuild the entire thing again.