Not getting Boot logs in console

Hello,

I have flashed linux kernel version 4.9 (L4T 32.4.4) Ubuntu 18.04 , in my Jetson NX SOM module carrier board.

  1. In order to get console access and get boot logs my setup is
    (A) connected BOARD to PC by microusb to USB cable ==> got ttyACM0 node ==> used , sudo minicom -D /dev/ttyACM0
    (B) connected BOARD to PC by USB-UART cable with pin no, pin8 TX ,pin10 Rx & pin14 GND ==> got ttyUSB0 node ==> used, putty ,

even after trying both the methods (although i get kernel logs by , dmesg) i am not getting boot logs but after few seconds it ask for login credentials (username and password)

.

Hello @vinay2010singh

Which serial port do you use? The serial port might be wrong to see logs. I recommend to check available serialports.

Best wishes.

Hello,

I have used this connection , i tried both methods by microusb-usb and serial port (usb-uart) connection.

In your “/boot/extlinux/extlinux.conf” do be sure that any occurrence of the token “quiet” is removed. If you see “quiet” anywhere in “cat /proc/cmdline”, then logging was told to be far less verbose to the console.

@WayneWWW Sir @Trumany Sir could you please give your valuable response

Hi vinay2010singh,

Please try connect TX/RX/GND cable on J14 pins3,4,7.
Reference detail from Xavier-NX User Guide.

1 Like

Thanks for replying , i found “quiet” in these many places,

  1. sudo vi /boot/extlinux/extlinux.conf LABEL primary MENU LABEL primary kernel LINUX /boot/Image INITRD /boot/initrd APPEND {cbootargs} quiet root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4
    console=ttyTCU0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0

     LABEL JetsonIO
     MENU LABEL Custom 40-pin Header Config
     LINUX /boot/Image
     FDT /boot/tegra194-p3668-all-p3509-0000-user-custom.dtb
     INITRD /boot/initrd
     APPEND ${cbootargs} **quiet** root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 
     console=ttyTCU0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0
    
  2. cat /proc/cmdline

console=ttyTCU0,115200 video=tegrafb no_console_suspend=1 earlycon=tegra_comb_uart,mmio32,0x0c168000 gpt usbcore.old_scheme_first=1 tegraid=19.1.2.0.0 maxcpus=6 boot.slot_suffix= boot.ratchetvalues=0.4.2 vpr_resize sdhci_tegra.en_boot_part_access=1 quiet root=/dev/mmcblk1p1 rw rootwait rootfstype=ext4 console=ttyTCU0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0

DO YOU FIND ANY REASON OF NOT GETTING BOOT LOGS…

thanks, it worked for me

As long as “quiet” appears logging will be reduced. Boot stages prior to the Linux kernel loading may look at this via the device tree. Normally, if extlinux.conf is present and specifies the option, then that is what is used, but there are also circumstances where a device tree might provide such options. Do you see “quiet” from this command?
cat /proc/device-tree/chosen/bootargs

If you don’t see “quiet” there, and don’t see quiet from “cat /proc/cmdline”, then you have succeeded at removing the option and do not need to look further (so far as simple options go).

Most of the Jetsons run Cboot, which then loads U-Boot, but the Xavier and NX boot directly from CBoot. I suppose it is possible there is some other option for the non-U-Boot releases to not log during pre-Linux-kernel stages, but I am not aware of any such compiled in option.

Are all instances of “quiet” removed? If you log boot via serial, is your first log line something like this:
Booting Linux on physical CPU
…or is there more content prior to that line? If the log begins with that line, then it is not logging prior to the Linux kernel. If there is more content prior to that line, then you’ve verified CBoot is doing at least some logging.