Not receiving audio from compute cluster(CloudXR 4.0)

Hi everyone,

It is fun working with CloudXR, however I am not able to get it to work on our compute clusters completely.

I have been using the APK provided by another user which has been great so far (highly recommend it): BattleAxeVR/OK_Cloud_Streamer: An Open-source CloudXR 4 client, based on OpenXR with OK performance and features. (github.com)

This works great when using my laptop as server and a Quest 3 as client. However, when using our compute clusters, I am not receiving any audio but the video stream still works great. As it works on when using my laptop as a server, I am not expecting the client to be the problem.

I have tried the following:

  • Not using RDP at all and logging in via tightVNC as I saw that could result in weird problems.

  • Double checked if the NVIDIA Virtual Audio device was added in the device manager (it is)
    - However in the Windows Sound settings it says: No audio devices are installed.

  • I looked into the logs, and next to spamming “Failed to query HKLM\SOFTWARE\NVIDiA…” It doesn’t seem to say anything specific to audio which is not working. (the streams are opening)

  • My ports are open from range 47998 till 48005, so that should include the video and audio ports. As the video is working, I can say the forwarding is working. (and 48010 for RTSP)

I am not sure anymore where to start debugging and which things to try. Any pointers would be highly appreciated. Thanks!

Same here, no audio - to be fair, already in 3.1.1. Weirdest thing even is, that the sound bars in sound settings on the VM show output activity on the NVIDIA Device.

This is definitely some kind of issue with how the NVIDIA Virtual Audio device is getting installed/registered.

As a workaround, can you try installing VB-Audio Virtual Apps, which should create an audio device on your VM that CloudXR can attach to and grab audio from?

Any details you all could share about your compute cluster deployment environment would be helpful for debugging: Windows OS version/variant, which GPU, whether and how the GPU is virtualized, etc.

@AndreusNvidius
Thanks, the virtual driver works to enable the audio!

Still having some issues with the screen, which I am not 100% sure where it comes from. It seems I am not able to connect directly when I do not stream the screen to my laptop, however when I turn RDP on via my laptop, then connect the headset(expected green screen in VR) and then turn RDP off that seems to do the trick. Haven’t been able to connect immediately without turning RDP on.

Hey, @Zulex123,

I recommend looking at this tool

There are a lot of issues around RDP / not RDP and how the display/desktop works on cloud / virtualized instances.

You might be interested in this talk from GTC, where a couple of us NVIDIANs discuss practical CloudXR deployment issues:

1 Like

Thanks @AndreusNvidius !

Really good talk, I’ll make sure to implement all the best practices now I got it to ‘work sort of’.