Not seeing cards, Mac Pro with gt120+gtx285. Installation trouble.

Have installed and uninstalled a number of times and nothing works.

Current version: Brand new Mac Pro 2x2.26. Slot 1, GTX285; slot 2, GT120; slot 4, raid controller. Monitor on the 120.

Installed drivers for the 285. It appears just fine. Both cards seen in the system profiler.

Installed toolkit 2.2. Had a lot of trouble with that earlier as the kext box appears unchecked by default in my machine, but now it’s installed.

$ kextstat | grep CUDA

106 0 0x59d000 0x2000 0x1000 com.nvidia.CUDA (1.1.0) <5 2>

Variables as per instructions:



Installed sdk 2.2. (I did rm -r the whole /Developer/CUDA tree prior to install). Made. Got trivial warnings.

$ bin/darwin/release/deviceQuery

CUDA Device Query (Runtime API) version (CUDART static linking)

There is no device supporting CUDA.

Device 0: “Device Emulation (CPU)”

CUDA Capability Major revision number: 9999


Previously, downgrading to 2.1 I had got completely nonsensical results (deviceQuery would return a single card, rather than 2, with a null string name, negative clock rate, 1 byte of RAM…). I removed the GT120, moved the monitor to the 285, repeat, same thing.

Will repeat again with 2.1 to see if the nonsensical part still keeps coming up.

Any clues are welcome—pretty please?

Please help!!! Nonsensical results!!!

I took out the 285, now I have only the gt120 on slot 2. Profiler sees it just fine. Uninstalled completely Cuda2.2, down to rm -r the kext and startup dirs. Rebooted for good measure. Reinstalled from scratch 2.1. The kext comes up fine.

Devicequery comes up with utter nonsense:

$ bin/darwin/release/deviceQuery
CUDA Device Query (Runtime API) version (CUDART static linking)

There is 1 device supporting CUDA

Device 0: “”
CUDA Capability Major revision number: -1073743496
CUDA Capability Minor revision number: -1881139086
Total amount of global memory: 0 bytes
Number of multiprocessors: 1
Number of cores: 8
Total amount of constant memory: 1 bytes
Total amount of shared memory per block: 0 bytes
Total number of registers available per block: 0
Warp size: -1881145344
Maximum number of threads per block: 12
Maximum sizes of each dimension of a block: 0 x -1881138560 x -1881083968
Maximum sizes of each dimension of a grid: 0 x -1881116725 x -1881139893
Maximum memory pitch: 0 bytes
Texture alignment: 4096 bytes
Clock rate: -1073.74 GHz
Concurrent copy and execution: No


All other demos abort with a “initialization failed”.

The kext is up and fine:
kextstat | grep CUDA
105 0 0x87774000 0x2000 0x1000 com.nvidia.CUDA (1.1.0) <5 2>

The profiler reports the gt120 as

NVIDIA GeForce GT 120:

Chipset Model: NVIDIA GeForce GT 120
Type: Display
Bus: PCIe
Slot: Slot-2
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0640
Revision ID: 0x00a1
ROM Revision: 3386
DELL 1901FP:
Resolution: 1280 x 1024 @ 60 Hz
Depth: 32-Bit Color
Core Image: Hardware Accelerated
Main Display: Yes
Mirror: Off
Online: Yes
Quartz Extreme: Supported
Rotation: Supported
Display Connector:
Status: No Display Connected

What is going on???!!!?

Did you install the drivers from the CD? You should do that and then install the toolkit. (we’re actually working to get a new package out to streamline this)

Yes, of course, I installed the 285 drivers from the 285 CD before installing the cards. Still, I took out the 285, and even with the gt120 that the mac pro came with, nonsense, as outlined in the previous post.

I had exactly the same problem and someone sent me a different version of the CUDA 2.2 Mac release that works. Seems like NVidia needs to update what is available on their site for the Mac.


Would you, pretty please, send me the “good” version??? I’ve gone nuts already, I’ve rebooted this baby at least 40 times since first power up less than 24 hours ago!!!

Pretty please? I opened my email settings.

Chris kindly emailed me the “good” version yesterday. I installed it and everything started working without even a need for a reboot.

Now everything works the way it was supposed to. Thanks Chris!


That’s great! It looks like I need the same drivers, so it would be wonderful if someone from NVidia could make the fix generally available soon.


working on it…

Thank you!

If you have a GT200 (ONLY if you have a GT200 and have installed the display driver from the CD included with your card), try this toolkit:…1_macos_32.pkg

Seems to work as well as the unofficial one.