[NOTABUG] offloading no longer works [problem with latest intel drivers]

Good day,
yesterday I have updated my gentoo box on laptop and stuff happened, my optimus offloading no longer works (not entirely sure nvidia-drivers is at fault, since older 334 drivers doesnt work either).

Here is xorg backtrace (just a few lines, so I don’t have to bother uploading it all):

[ 1361.945] (EE) Backtrace:
[ 1361.945] (EE) 0: /usr/bin/X (xorg_backtrace+0x86) [0x7f909382e2c6]
[ 1361.945] (EE) 1: /usr/bin/X (0x7f9093645000+0x1edca0) [0x7f9093832ca0]
[ 1361.945] (EE) 2: /lib64/libpthread.so.0 (0x7f90929db000+0x11640) [0x7f90929ec640]
[ 1361.945] (EE) 3: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7f908cc78000+0x6ada6) [0x7f908cce2da6]
[ 1361.946] (EE) 4: /usr/bin/X (xf86DisableUnusedFunctions+0xeb) [0x7f909372e2ab]
[ 1361.946] (EE) 5: /usr/bin/X (0x7f9093645000+0xf4245) [0x7f9093739245]
[ 1361.946] (EE) 6: /usr/bin/X (RRCrtcSet+0x2cb) [0x7f909377ef4b]
[ 1361.946] (EE) 7: /usr/bin/X (ProcRRSetCrtcConfig+0x3d9) [0x7f90937806b9]
[ 1361.946] (EE) 8: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f908cff9000+0x552e99) [0x7f908d54be99]
[ 1361.946] (EE) 9: /usr/bin/X (0x7f9093645000+0x5c1ee) [0x7f90936a11ee]
[ 1361.946] (EE) 10: /usr/bin/X (0x7f9093645000+0x60c0a) [0x7f90936a5c0a]
[ 1361.947] (EE) 11: /lib64/libc.so.6 (__libc_start_main+0x11b) [0x7f9091c85feb]
[ 1361.947] (EE) 12: /usr/bin/X (0x7f9093645000+0x483c9) [0x7f909368d3c9]
[ 1361.947] (EE)
[ 1361.947] (EE) Segmentation fault at address 0x0

EDIT: Reverted to stable intel drivers and everything works as expected, please close thread but don’t delete it (I will report on intel bugzilla/mailinglist/forums).

EDIT2: relevant bug @intel side bugzilla (https://bugs.freedesktop.org/show_bug.cgi?id=77283)

EDIT3: intel bug resolved upstream [chris willson].