Nothing displayed on HDMI monitor

I have Jetson Xavier NX that is connected to a DELL monitor through HDMI.
After flashing the image of jetpack on a 32GB microSD card, it worked good for few days.
For making the setup towards bazel, I was installing few updates by apt.
The next day morning when I powered on the Jetson Xavier NX with power supply, and connected monitor through HDMI, nothing shows up on monitor except the green light on Jetson Xavier NX being ON.
Kindly help in further steps.

Assuming this is a dev kit and not a third party carrier, this should work. However, to debug video, it is recommended to use a serial console to get a boot log. See:
https://www.jetsonhacks.com/2019/04/19/jetson-nano-serial-console/
(serial console is the same on both NX and Nano)

Serial console shows logs from even in earlier boot stages as well, and logs to your host PC, so you can directly attach a log file to the forum with serial console (versus having to take screenshots of some otherwise difficult to reach Jetson).

A compromise is that perhaps ssh works (though probably not since you would not have completed first boot account setup). If you do have an account ready and can ssh in, then you could provide the “dmesg” log.

Note that if you have an eMMC model (not a dev kit), then this requires a different flash and you would not normally boot via SD card (you’d have to modify your steps). If this is a third party carrier board, then it has to use that manufacturer’s device tree/firmware.

Hi @linuxdev,

Thanks for the response. After going over above link to get the boot log through serial console, it needs a extra hardware (TTL to Serial converter). I would get it soon and post here the boot log.

Though already things were configured in this Dev Kit, I will explore further about ssh and post here when it is successful.

@rajap.nitc
try also connecting the nano to Host PC via usb cable [ USB-A to micro USB-B]
then executing from the host PC:

sudo apt install picocom -y
 sudo picocom /dev/ttyACM0

@Andrey1984,
Thanks for your help.
I attempted above suggested commands.
sudo apt install picocom -y —> Successful.
sudo picocom /dev/ttyACM0 —> returned as below :
picocom v2.2

port is : /dev/ttyACM0
flowcontrol : none
baudrate is : 9600
parity is : none
databits are : 8
stopbits are : 1
escape is : C-a
local echo is : no
noinit is : no
noreset is : no
nolock is : no
send_cmd is : sz -vv
receive_cmd is : rz -vv -E
imap is :
omap is :
emap is : crcrlf,delbs,

FATAL: cannot open /dev/ttyACM0: No such file or directory

@rajap.nitc
was the cable USB-A [ host PC] <----->USB-B micro [ Jetson nano board] presented by the time of the trial?
sometimes it also takes to restart the NX to get it working over USB
NX needs to be powered ON [ green led radiating] by the time of the trial

@Andrey1984,

Yes, the cable USB-A [ host PC] <----->USB-B micro [ Jetson nano board] presented by the time of the trial.
Below is the sequence that I followed :

  1. Power On laptop
  2. Connect the USB cable between host PC and Jetson Xavier NX.
  3. Power On the Jetson Xavier NX.
  4. Wait for few minutes and send picocom command on terminal
  5. The response received is “FATAL: cannot open /dev/ttyACM0: No such file or directory”

If you monitor “dmesg --follow” on the PC, and then connect the USB connector, what shows up in that log? Perhaps it is some other label than ACM0? The log would say what the UART name is.

Attaching the boot log, where the last line says :
kernel boot failedJetsonBootLog.txt (20.2 KB)

@linuxdev, @Andrey1984 Could you analyse the log and suggest me how to get out of the problem. Please share what could have went wrong here…

Please let me know if there is any issue in viewing the log

0017.271] I> T19x: Authenticate kernel-dtb (bin_type: 38), max size 0x400000
[0017.274] I> Loading ramdisk from rootfs …
[0017.274] I> rootfs path: /sd/boot/initrd
[0021.404] I> lookup_linear_dir:441: Invalid file block num
[0021.404] I> ext2_walk:142: ‘initrd’ lookup failed
[0021.405] I> ext4_open_file:647: ‘/boot/initrd’ lookup failed
[0021.405] E> file /sd/boot/initrd open failed!!
[0021.405] E> SD boot failed, err: 202113041

How did you prepare your image? It looks corrupted.

@WayneWWW, the preparation of image happened by following below link :

Moreover it worked for several weeks. I could work on it as a regular computer.
When attempted to setup bazel, ISAAC and its pre-requisites, this problem happened.

Probably something ruins the initrd when you install bazel and Isaac.

Can you confirm what command is crashing the device?

@WayneWWW,

How to find which command is crashing the device ?

The day I was experimenting with several installation, nothing was shown as system level issue, though there were some failures in installation, due to missing packages support. The next day, when I powered ON, I found this issue.
Whether redoing the “Getting Started With Jetson Xavier NX Developer Kit” shall be a good option ?
Or do you suggest any other things ?

The process of locating the cause may be painful.

What I want to know is if there is a process that we can repeat and it will definitely reproduce your issue.

For example, start with a clean image which can boot up without problem.

Then, try to install those you want again and see if you can reproduce issue.
Sometimes the error may happen after your reboot. Such case is very common when dealing with system side issue. Take kernel image for example, you can delete the kernel image file and the system will still work fine at that moment. But it will definitely die in next reboot. Maybe initrd hits same case on your device.

@WayneWWW,
Are you saying that even if I redo “Getting Started With Jetson Xavier NX Developer Kit”, the problem shall persist ?

Hi,

I mean you can firstly go back to the fresh image, which is definitely working.
However, what I concern is if you install something, you may hit this problem again. Thus, I need to know what is causing this problem. Finding the cause of this problem is more important.

@rajap.nitc

what i scapacity of your sdcard? is it 8gb? 16gb? 32gb? else?
maybe it is a space related issue?
I couldn’t get IsaaC/ Bazel to corrupt NX at my trials

Hi @Andrey1984 and @WayneWWW,

Thanks for your help and inputs.
After preparing memory card that is of capacity 32GB, freshly(previously also I used the same) again, the problem is resolved. i.e., now the display shows up properly.
Could you please let me know, whether bezel installation is expected to happen on Jetson device only ?

it depends:
bazel can be either assembled manually or through isaac scripts or otherwise
e.g. on host PC it gets installed using isaac scripts if using the ISaaC