Nsight 3.0 (final version) ignoring shader changes

I have installed the final version of Nsight 3.0 for Visual Studio. I am using the MSVS 2010 Pro version in a Windows 7 64 bits, nVidia GTX 680, driver version 320.00. After debugging a shader for the first time (which worked flawlessly – good work :D ), the debugger started ignoring all changes I made in the source file after that debug session, skipping all lines I had added in all subsequent debug sessions.

Is there something I am doing wrong? I am editing my shaders inside Visual Studio, and the shaders are in the root directory of my project. I have also tried dynamic shader editing, but even so all my changes were ignored.

Thx in advance,


This is really frustrating… All shaders are compiled via D3DX11CompileFromFile with the flags informed in the help file, I can debug all my shaders, but if I edit them, it seems all my changes are ignored and the original shader is executed instead. I have tried two different computers, tried to erase all files not being source code and the MSVS project files, tried resetting the Nsight monitor…

I have run out of ideas. I just want to be able to edit my shaders…

Any ideas?



Please check this tutorial video for dynamic shader editing feature.

Thanks, but I had already tried that.

I finally got it to work by creating a new project and then copying my source files.