Nsight 4.0 on Optimus Laptop

I have an Optimus-enabled laptop that has the Intel 4000 and GeForce GT 555M graphics processors.

Through the Nvidia Control Panel, I have opted to use the GeForce as the preferred graphics processor.

I can “Start Graphics Debugging” in VS2012 but pausing and capturing a frame shows this message:

In the NVidia Control Panel -> Manage 3D Settings, for MSVC (devenv.exe), “Integrated graphics” is selected and grayed out, so I cannot change it.

Incidentally, I can scrub through the frame so it seems the frame capture worked, but I don’t know how much functionality I’m missing out on due to Nsight using the wrong GPU.

Exactly same problem here on laptop with an Intel HD Graphics 3000 (integrated GPU) + NVIDIA GeForce GT 630M. Visual Studio 2013, Nsight, and both of my GPU drivers are up-to-date. Does anyone know at least the reason why the GPU selector is disabled for “devenv.exe”?

EDIT: Probably, the title should be changed to “Nsight 4.X on dual GPU machines” or something like that.

Hi protongun, Alexaltea,

“devenv.exe” is forced by Optimus system to use iGPU, there is no way to fix it for external guys. But there are some way which may help you jump over this gap:

  • disable you iGPU in BIOS, then devenv.exe has no other choice but use your dGPU
  • update your iGPU driver, make it support OGL 3.3
  • connect the port which connect to your dGPU to some external monitor, for example, some DP or HDMI port is connect to dGPU directly, active these port and make devenv.exe show in corresponding monitor will make it use dGPU

Ps, @protongun, I can’t watch your image, please attach the image directly, but not use some external URL.

Thanks
An

Hi AYan,

Long time has passed since my last message. I never managed to solve the problem, and eventually stopped caring about it. With the release of Direct3D12 last year, I am facing once again the exact same issue, this time on Visual Studio 2015 and Nsight 5.0. This is the current state:

Disable you iGPU in BIOS, then devenv.exe has no other choice but use your dGPU

My laptop manufacturer removed that setting from the BIOS. While I managed to patch the BIOS to avoid this restriction, disabling the iGPU causes all video outputs (laptop screen and HDMI) to stop giving a signal. Reverting this requires to remove the CMOS battery or blindly going through the BIOS menus to reenable it.

Update your iGPU driver, make it support OGL 3.3

Pointless with this iGPU (Intel HD Graphics 3000). The drivers support only up to OpenGL 3.1 and Direct3D 10.1.

Connect the port which connect to your dGPU to some external monitor, for example, some DP or HDMI port is connect to dGPU directly, active these port and make devenv.exe show in corresponding monitor will make it use dGPU

Not the case for my laptop. The iGPU still overrides the dGPU regardless of the screen/settings.

I realize that just buying a new desktop PC would be the easy solution. However, my dGPU, an Nvidia GT 630M is compatible with the APIs I need to work with, despite of its comparatively not-so-great performance. Nvidia Optimus has been the source of all this trouble from the beginning, and I am honestly not sure who should I contact about this.

  • Is this even the correct subforum? I’m not sure who else could I contact, as Acer and Intel do not care about this.
  • Is there any guarantees that I won’t be facing this iGPU-overriding-dGPU issue with newer Intel HD 5XX + Nvidia GTX 9XX laptops?

Thanks for your time and attention.

Hi AlexAltea,

The original thread’s screen shot just means Nsight needs to use OGL 3.3 in some UI widget. To jump over this issue, you might need to use a more powerful GPU.

On Win10 platform, there is another technical name Hybrid graphics, which is similar to Nvidia Optimus, but there are not the twins. I am sorry to say that Nsight don’t support Win10 Hybrid right now.

Disable the iGPU depends on your laptop, for example, my ThinkPad T420s support disable iGPU and can run Nsight on Win7/Win10 smoothly to debug the local graphics samples. I am not sure about your laptop, and hard for me to test that, but you need to search the BIOS settings about GPU prefer or something like that.

Thanks
An