Nsight 4.0 RC1 - erroneous Tesla/Quadro discrepancy - cannot debug graphics

I have recently upgraded to Visual Studio 2013 and Nsight 4.0 RC1. My first attempt at starting a graphics debugging session resulted in a generic error (something like, Nsight could not attach the graphics debugger).

I soon discovered this was simply because of a file of my own failing to load during initialisation, seemingly because the working directory wasn’t what I was expecting, and thus throwing a FileNotFound exception. (e.g., It was trying to load my file from C:\MyProject\ rather than C:\MyProject\bin\x86\Debug) Bizarrely enough, the crash reporter window did show up, but I didn’t realise because it had shown up hidden in the background. (Also, auto-hidden taskbar.)

At some point during my investigating and fiddling (before realising the stupid file problem), I started getting a new error: “A Tesla-architecture GPU was detected in your system. Tesla-architecture GPUs are no longer supported for graphics debugging or graphics performance analysis.”

I’m on an HP Compaq 8710w latop with a Quadro FX 1600M GPU (v334.95, Windows 8 x64). Unless I’m stupidly ignorant, it has nothing to do with Tesla. Though it’s not listed in the supported GPU list, I never had trouble with Nsight 3.2.2/VS2012. Have these older Quadro chips suddenly become too outdated for this new version? And even if so, why is it that this wasn’t an issue for my first few attemps in 4.0 RC1?

I’ve ruled out the possibility of my FileNotFound exception being the issue by renaming the file and forcing the exception to be thrown. My program immediately exits and prompts the crash reporter (again, hidden in the background), but the same Tesla error dialog is still appearing.

It also may be worth noting that I tried debugging my project in VS2012 after installing Nsight 4.0 RC1, but I get the same error there.


The error message you are receiving about “Tesla-architecture GPUs” is expected. Starting with Nsight 4.0, Tesla-architecture based GPUs (meaning, prior to the Fermi-architecture based GPUs) will no longer be supported.
It could be that Nsight didn’t get to check for the GPU type on the system as you were experiencing the working directory problem. After you corrected that, it was able to get further and check on the GPU type, therefore giving the error message.

However, there shouldn’t be any crashes related to this, unless there’s more issues like the working directory issue you mentioned. I’ll double check with our testing team to make sure we don’t have any issues there.

Also, I’ll check on why the crash report is coming on the background.