Nsight cannot install tool libraries

When I target nsight to an Ubuntu server from a Windows machine, it connects but I then get “Tool libraries installation failed”. More specifically the message says:

DaemonStartError (1405) {

  • OriginalExceptionClass: struct boost::wrapexcept*
  • OriginalFile: C:\dvs\p4\build\sw\devtools\Agora\Rel\QuadD_Main\QuadD\Host\Analysis\SshDevice.cpp*
  • OriginalLine: 2293*
  • OriginalFunction: void __cdecl QuadDAnalysis::SshDevice::DeployDeps(void)*
  • ErrorText: Failed to create symlinks.*
  • ExitCode: 1*

Firewall is disabled on the target. The strange thing is that I successfully used nsight for a couple of days with no issues, then installed nsight compute on my windows client and nsight systems stopped working.
Tried to uninstall compute, nothing.
Tried to reinstall nsight systems…no luck…

this is what i get when i run nsys status --environment on the target:

Timestamp counter supported: Yes

Sampling Environment Check
Root privilege: disabled
Linux Kernel Paranoid Level = 4: Fail
Linux Distribution = Ubuntu
Linux Kernel Version = 5.15.0-56-generic: OK
Linux perf_event_open syscall available: Fail
Sampling trigger event available: Fail
Intel(c) Last Branch Record support: Not Available
Sampling Environment: Fail

See ‘Requirements for x86_64, Power, and ARM SBSA Targets on Linux’ documentation
for information on how to correctly set the Linux Kernel Paranoid Level.
See the product documentation at Nsight Systems Documentation for more information

can anyone help me solve the issue?
thanks a lot

As suggested here I managed to geti it working by installing the whole cuda toolkit on my windows machine. (Note that the nsight system version included in the cuda toolkit is the same one I was using as a standalone (2022.42)). I noticed that during startup of the connection to the target, this version goes through a “Daemon installation” phase…the stand alone version used to skip that.


I solved this problem using below command

rm -rf ~/.local/share/nsight_systems


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.