Nsight compute can't get the report in VMware

Since my system is windows10, I installed VMware of linux 20.04 to test nsight compute, and the device of remote launch was AGX Orin. I also completed the configuration and installation of Host through SDKmanager. As shown in the picture below, I successfully connected AGX Orin remotely through Nsight sysem:
However, when I used “Analyze the selected Kernel with Nsight compute” in Nsight system, the report cannot be generated successfully, resulting in the following problems:
the device:
VMware Linux 20.04
Jetpack 5.1
my question: Does the linux of VMware not support compute analysis?

Which version of Nsight Systems are you using?
From the screen shot nsight compute profiling completed successfully. There was an issue in transferring the data back to the host.

As a workaround you can ssh to the AGX Orin target and run the ncu command line on the target manually and copy back the ncu profiler output file to the host and then use Nsight Compute UI on the host to open and view the Nsight Compute kernel profiling results.

The version of Nsight compute I used is 2022.2.1. And I know how to use CLI to generate “.ncu-rep” files, but I want to generate the file through GUI. May I ask why the host of VMware cannot transfer data?

Did you try connecting to the Orin target from the Nsight Compute GUI directly or was it always launched through Nsight Systems? If you haven’t tried, can you use the Nsight Compute GUI directly and set it up to remotely connect and profile the application on the Orin?

One thing that could be happening is that the Orin target is not able to communicate back to the host. This could be due to port issues. This is usually because the required ports are not open, or otherwise accessible through a firewall. In this case it is trying to use port 50152. Can you make sure that this port can be used? If it is not possible to use this port then another can be configured using the options panel shown below. As seen here, it will attempt to communicate with the host using ports 50152 to 50162.

When I used SSH to connect the AGX Orin on VMware’s Linux, it worked, as shown in:

Then I set the Target’s Base Port is 10522, as shown in:

But it still generates the same problem:


I solved the problem. File generation can be completed only when the local host, VMware, and AGX Orin are in the same LAN!!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.