Nsight Compute won't run on non-english windows

I tried to use Nsight Compute on Korean Windows 10.
but Error message “lookup error unknown encoding cp949” was shown in the CLI.
so I tried change windows system locale to Unicode(cp65001; beta on windows10) from Koren(cp949).
and then the Error message is changed to “lookup error unknown encoding cp65001”.

I think that error may cause the system locale and not show on English system locale.
therefore finally, I changed the windows system locale to English and then Nsight Compute works.

I think that the error message is the python error message.

Please fix this error ASAP.


Thanks for reporting the issue.

We reproduced the issue internally and will work on a fix.


Until the issue is fixed in a newer release of Nsight Compute, you should be able to workaround the problem by setting the environment variable PYTHONIOENCODING=UTF-8

It seems the workaround is not working in Nsigiht system 2022.2.1.

Can you please confirm that you are using Nsight Systems?
Note that the original issue was reported for Nsight Compute.

Yes, I am using Nsight Systems. This is the screenshot.

Can you please create a new post under the Development Tools->Nsight Systems category?

The new topic is created at Nsight Systems won’t run on non-english windows