Nsight detects graphics card, doesn't show any GPU output for Trace Application


I have tried running the simple streams sample using Nsight. On the activity page, the connection status is green (and says TITAN X (Pascal) (Unknown)). After running Trace Application, on the summary report page produced, GPU 0 under CUDA Overview is greyed out. In the timeline, only cudaDeviceReset is shown.

I have recently upgraded to the Titan X; I had no problems previously using the GTX 660 Ti with Nsight version 4.2. After upgrading, I installed the Nsight version 5.1 (which is what I am using now) (I didn’t test the older version of Nsight with the new graphics card). Current graphics driver version = 372.54.

Hope that is enough information.

Hi lknight,

Looks like a driver issue, could you check the gpu information in NVIDIA control panel, if it isn’t correct, please reinstall the driver again, clean install is better. If the control panel shows the correct gpu, maybe it’s a issue of Nsight.

Best Regards

Hi harryz_,

It shows the correct GPU in the NVIDIA control panel. I might try installing an earlier version of Nsight and see what happens.


Ok, it works now. Just needed to install the RC of version 5.2. Noticed it would probably work when, instead of saying “TITAN X (Pascal) (Unknown)” under connection status on the activity page, it said “TITAN X (Pascal) (GP102)”.

Moral of the story: just install the newest version when you have the chance.