Nsight Eclipse : Opencv Error

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
[O] NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[O] Linux

Hardware Platform
[O] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
[O] native Ubuntu 18.04

Hello, I just installed Opencv in my HOST PC and Tegra by referring to the Nvidia site(OpenCV - compile OpenCV 4.1.1 on Drive Software 10.0).

But the problem is that the Nsight Eclipse IDE can’t find the OpenCV package.
I just set the include path and library but it’s not working.
I will attach the screenshot about the error, can anyone give me any advice?

I haven’t tried the steps in the tutorial, not to say I haven’t tried nsight eclipse based on it before. But it’s important to double-check the location of opencv2/opencv.hpp on your host machine to make sure the include path is correct.

As I attached the screehshot of the include path, I double checked the location of the opencv2/opencv.hpp on my HOST PC.

Is there any other way to solve it?

Did you manage to locate the opencv.hpp file? Are you still encountering the same error when running the command in the console (not through nsight eclipse)?

  1. Yes I located the opencv.hpp files at the same path(/usr/local/include/opencv).

  2. What do you mean in the console? (You mean Vscode?)
    When I used VScode before it occured same problem.

If that’s the case, it seems nothing to do with nsight eclipse.
I guess you may need to check how to use OpenCV with CMake and modify your CMakeList.txt file.

I want to make the CMAKE environment in VScode (not in Nsight Eclipse).
Is there any manual to make the CMAKE environment in VScode?

I would recommend checking the VSCode support site or posting a question on the VSCode community forums for further assistance.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.