Nsight error: unsupported GNU version! gcc versions later than 6 are not supported!

I am getting this error in the title. I am following this example https://devblogs.nvidia.com/cuda-jetson-nvidia-nsight-eclipse-edition/

Do I have to install an earlier version of gcc?

Hi,

May I know which JetPack version do you use first?
Suppose you can launch Nsight directly after the sdkmanager installation.

Thanks.

I was using the wrong Nsight version.

I was using version 9. Version 10 works.

Thanks. Good to know this.

I was having trouble opening Nsight 10 that came with the CUDA toolkit. So I installed Nsight 9 and was using that. I am able to use Nsight 10 now, and that error is not a problem. Thanks.