Nsight graphics debugging won't let application connect to the internet


I am debugging an application using Nsight Visual Studio Edition and while running the graphics debugging my application can’t connect to the internet.

The game saves all it’s information on the internet so it won’t run without an internet connection(just goes to an error screen but I need to debug elements in game).

I have tried changing the port on which the monitor and the debugger work thinking that they block the application but it still doesn’t work.

The application works normally when I’m not debugging using Nsight so it’ nothing trivial like no internet connection or errors in the application.

Anybody have any idea?

Thank you very much,
Adrian Jurca

Hi Adrian,

Do you use any custom libraries for network access?


Hi Jeff,

Nothing custom. I use cURL for the internet connection. And the error I get is that cURL can’t connect to the server.

I’m thinking that this has something to do with the fact that the Nsight debugger connects to the monitoring server and that makes all connections route through that server, which has not internet connection.

Thanks for the interest in my question,

Hi Adrian,

So, is setup for debugging remotely with Nsight? Meaning, you have two machines (one with Visual Studio) and the other one with the application and Nsight Monitor, so when you do Nsight debugging, computer 1 (with VS) connects to computer 2 and starts the debug session? if so, are you able to run the application successfully (without Nsight) on computer 2?

Is there a way for us to get a set of binaries to try to reproduce this internally?


Hello rafi,

Sorry for the late replay, I don’t seem to be getting emails from this forum( I’ll have to check the settings :) )

No, I’m running the application and VS with Nsight on the same computer. And the application runs fine if I’m not debugging using Nsight.

Unfortunately I can’t provide binaries, but I think you can reproduce it by using any graphics application and from it make an http request to any server or link using the cURL library.

Normal behavior with normal VS debug mode should be that the request works properly. If this issue problem reproduces, when debugging with Nsight( Start Graphics Debugging ), the request should fail with a “Could not connect to server!” error. If it doesn’t reproduce this means that the issue has no relation to the cURL library and it’s something application specific.

I have not tried creating another simple application to try this out because I did not have time and the problem I wanted to debug in the first place got solved another way.

I would like to pursue this issue though in case anyone else runs into a problem like this. I might need it myself later on if I need to debug something else in the shaders of that application.

Thanks for your help.

Hi Adrian,

I quickly tried Graphics Debugging against a libcurl program, but I was able to connect and download fine. Which graphics library are you using (DX/GL)? And did you build libcurl from source, or did you use a binary? Which bitness (32/64) is your program being compiled in?




Using GL and cURL is built from source. Everything is built in 32 bit. Just in case it matters, I’m using Visual Studio 2008 with the latest version of Nsight(the one that came out just a few days or weeks ago, can’t remember, but I know I updated).

Did you use the latest version of cURL? I seem to have an older version and I’ll have to try with a newer version.

Thanks a lot for trying this out.

I’ll try changing the version of cURL and I’ll post back my results.


So, I tried updating cURL, but no dice. Still didn’t work.

Conclusion: it’s something application specific and unfortunately I have no time to find out what.

If I ever get time to work on this application again and I find what the problem is I’ll post it here.

Thanks for all your input.

All the best,

Hi Adrian,

Sorry we couldn’t figure out what is causing the issue. If you find out any more information, please let me know. I really appreciate your feedback.