Nsight Graphics - no processes in 'Attach' tab

Hi, sorry to post this here but there isn’t yet a forum for Nsight the standalone version.

In the UI, there is an Attach tab (since Launch is failing to inject for me), but it doesn’t list any processes despite lots of processes running on my machine. I’ve tried many graphical applications including my own and the process/PID list remains empty.

Is this not a working feature?

Hi relaxok,

If the process is not launched via Nsight Graphics, you cannot see the process in the Attach tab.
However, I’m concerned about the launch failure, could you please provide more information?

  • OS
  • GPU
  • Driver
  • Nsight Graphics version
  • your application’s graphics API (Vulkan, DX11, DX12, OpenGL)
  • detailed steps of reproduce Launch failure
  • any log output when injection failure happens?
  • Does the launch failure happen on other applications?


Okay that answers that question!

OS - Windows 10
GPU - GeForce GT 750 M
Driver - 397.64
API - DX11
Steps - happens immediately upon launching from the Launch tab
Log - Only log is that it says ‘Launch failure’ right after Launching… (if you mean the Progress Log)
Other apps - most work fine

Now I should say this is a 3rd party app not mine, so maybe it’s intentionally obfuscated due to other startup anti-cheat code or something.

However it would be nice if it just worked in general. Intel GPA seems to have no trouble with the app. Maybe they inject later bypassing some potential startup problems? NSight is so much better though, overall! This happens even when ‘Automatically connect’ is unchecked, fwiw.

But I understand if this is not your intended use.

Also wanted to add, NSight used to work fine with it on previous versions (of the app) so I’m still assuming startup obfuscation is the problem.


Thanks for the quick reply.

Is this application a game? Some games do have mechanics that doesn’t allow process to be attached or something. Can you share the application with us for further investigation?

And you mentioned Intel GPA, are you running this application on hybrid laptop? If yes, can you make sure the application is running on Nvidia GPU? You can set it in Nvidia Control Panel, Manage 3D settings.


Yep, it is a game. It’s the current World of Warcraft Beta application (WowB.exe), though I believe it also fails on the current live retail version of the game client.

The game is definitely running on Nvidia GPU. Intel GPA can also frame capture/debug anything using DX11 even if it’s an Nvidia GPU. It’s just a much worse application than Nsight and is missing many features (can’t look at vertex buffers for example). However it can attach after the fact to this application no problem. Maybe it works via a different method for injection.

Anyhow, I develop my own software too but used to like to use Nsight to debug other games to see how they are drawing frames too, and I’m very disappointed that I’m now unable to, even if that’s not the precise purpose of your software. I’m sure many others even in the game industry use it like that as well.

If you want to try it and maybe want to see how it’s failing, you can download/install the game on a trial for free.


Thanks for the reply.
It’s a known issue that Battle.net games fail to launch via Nsight because it detects debugger and tear itself down.
We’ll let you know if there’s an update on this issue.