NSight local debugger connnect and disconnected immediately

Just installed VS2008, CUDA 5 and NSight 3.0 on my computer with Windows 7 OS and Tesla C2075 GPU. I tried to set localhost in the launch option which is required by local debugging and disabled secure connection because this is only local debugger (tried to enable it too but it did not work either), as described here:

But whenever I clicked “start CUDA debugging” the program exits and on the right corner of the screen it shows “NSight Connected xxx to xxx” and then immediately shows “NSight Disconnected xxx from xxx”.
I searched the forum and tried to use google. I can find some posts with similar problem but none was properly resolved.
Anybody knows?

I had similar problem with OpenGL and resolved it by breakpointing before all my OpenGL calls. I found a call that just caused the debugger to exit. I remcved the call and it all worked. I also put the call in a simpler program and it worked.

I know this is not a complete solution but it appears I have some combination of calls that cause the debugger to fail. When I get a chance I am going to try to find the combination.

There could be a runtime error that is causing the program to exit early. Are the working directories and paths set correctly for your project properties and Nsight properties?

I had the same problem and I hope this post may help someone in the future. After checking the requirements of Nsight VSE (Visual Studio Edition), I realized that there is a list of supported GPUs that doesn’t include Tesla C2075 GPU. Please check this link https://developer.nvidia.com/nsight-visual-studio-edition-supported-gpus-full-list