NSIGHT Mem-Checker internal error (code packing)

I want to check our library for access-violations (cause i get a unspecified launch error in kernel sometimes).

So I activate the CUDA-Memchecker tool in Visual Studio NSIGHT

During running the program in the debugging session, I get the error (on NSIGHT output window)

CUDA module loaded: 5f4a1180 K:/common/libs/Cuda/CudaCVCore/src/CudaCVCoreTrackFeatures.cu
Internal debugger error occurred while attempting to load Z20d_trackFeaturesPyrLKILi2ELi1EEviiiPfS0_S0_S0_ifS0 in CUcontext 0x03de9cb0, CUmodule 0x5f4a1780:
failed to allocate code patching memory from driver.
All breakpoints for function Z20d_trackFeaturesPyrLKILi2ELi1EEviiiPfS0_S0_S0_ifS0 have been removed.

And the debugging session closes.

What can I do to avoid this error, so that the debugging session finishes ?

I tried to increase the code packing factor from 2 to 32, as mentioned in http://http.developer.nvidia.com/NsightVisualStudio/2.2/Documentation/UserGuide/HTML/Content/Use_Memory_Checker.htm - but that didn’t help.

I am using VS 2013, Cuda Toolkit 7.0 (64-bit), NSIGHT 4.5 on a Windows 7 system

Hello HannesF99,

Could you tell me which GPU you use, it looks like your GPU doesn’t have enough memory for code patching.

Best Regards

It is a gtx 960 with 2 GB memory

Hello HannesF99,

I’ve seen the same error at stackoverflow before, please check the link below.

I suggest you to increase the code packing factor, if it still doesn’t work, please have a try on latest Nsight build which is 5.1.

If you want to check the cuda memory issue, cuda-memcheck.exe under cuda install path also can help you.

Best Regards
Harry