Nsight - OpenGL Debugging

Hi Guys,

I have nsight running on Ubuntu and I have a Jetson Nano.

I can build and run OpenGL code from Nsight on the nano, the OpenGL windows open up in X fine on the monitor connected via HDMI.

When I try to debug I run into problems, I have the remote connection logging in as root, I have root enabled on X.

I have tried with local builds and remote builds to aarch64.

I get the problem either at glutinit() or glutCreateWindow():

RemoteMandel on root_192.168.1.174 [C/C++ Remote Application]	
	Host Process [RemoteMandel] [8100] [cores: 3]	
		Thread [1] 8100 [core: 3] (Suspended : Step)	
			_dl_catch_exception() at 0x7fb7bfeb5c	
			_dl_catch_error() at 0x7fb7bfec10	
			dlerror() at 0x7fb7e07778	
			dlsym() at 0x7fb7e071f0	
			glFramebufferTextureMultisampleMultiviewOVR() at 0x7fb66180b0	
			_dl_rtld_di_serinfo() at 0x7fb7fdf898	
			_dl_rtld_di_serinfo() at 0x7fb7fdf9e8	
			_dl_find_dso_for_object() at 0x7fb7fe3b98	
			_dl_catch_exception() at 0x7fb7bfeb6c	
	Remote Shell	

Has anyone any ideas?

Many thanks


Some more info, it all works fine from the command line.

So on Jetson I run:

/usr/local/cuda-10.0/bin/cuda-gdbserver :2345 ./Mandelbrot

On my Ubuntu machine I run:

/usr/local/cuda-10.0/bin/cuda-gdb --interpreter mi2 --nx --cuda-use-lockfile=0

And then target the remote gdb server, I can step over the code that causes issues in nsight and can run the app and see the OpenGL window on the HDMI output, everything works.

So why doesn’t it work from the IDE?

You can check the gdb traces from Nsight EE that will give the details of all commands send from Nsight EE to cuda-gdbserver.

From Console view-> Click the drop down next to TV like icon-> Select GDB traces.

That would give some clue on which command is failing in the IDE.