Nsight stopped profiling too soon

I am using Nsight Systems 2021.1.3. with Visual Studio 2017 on Windows10. Nsight Systems automatically closes the launched program in 4s before entering the kernels that I want to profile. I checked in the user guide that I can adjust the duration by -X (–stop-on-exit). I don’t know what is the equivalent operation in Visual Studio. I tried changing the connection timeout in the Nsight Sytems option. But the program still got shutdown automatically. I want to find a way to elongate the duration of profiling.

What is the command line you are using? Or if you are running from the GUI, what is the application and arguments you are giving Nsys.

I don’t give any arguments in the Nsight GUI. It is just the .exe. What should I fill in there? --stop-on-exit?

@liuyis, can you take a look at this?

Hi lijing070769,

I downloaded PainlessMG and built it with Visual Studio 2019 + CUDA Toolkit 10.1.

Using the recently released Nsight Systems 2021.3.1, I can trace CUDA and OpenGL in this app successfully on my Win10-64 station.

See project settings below.

I hope this helps.


Hi I tried matching everything in screenshot. However, Nsight still stopped profiling for 6-10s before entering the actual GPU code. I’ve got nothing interesting in the report. The Diagnostic Summary shows that No CUDA events collected. Does the process use CUDA? I am using NVDIA Geforce RTX 3060, the driver version is 461.72. (I tried version 465, which doesn’t work either). I am using Nsight system 2021.1.3.

Hi @lijing070769, could you try if it works under Nsight system 2021.3, our latest public release?

@liuyis It works now with Nsight system 2021.3. Thanks!

1 Like