NSight System 2019.6.1 does not have option to attach to pid on target

Hi,

I am trying to use NSight System 2019.6.1 to profile application on Linux PC target. I am having a problem to start the application from the NSight on Host. So I looked for the feature to attach a target Process PID on NSight but it seems there is no such options. I also tried 2019.5.1 but the same problem. Please see screen. Please help.

screen shot:

Unfortunately, the X86 Nsight Systems does not support attaching to a running process. May I ask what problem you were having launching the application from the Nsys host?

Why not support attaching on X86 target. Does it possible to support in the future? I hope to profile online services, restarting the service will bring side effects.
Looking forward to your reply.

Hi Lmxx1234567,

There are no plans to add support for attaching to a running process on Linux x86_64 systems at this time. Nsight Systems needs to launch the application in order to properly inject it which enables API tracing.

Have you explored the Nsight Systems CLI commands? One possibility would be to launch the process with the ‘nsys launch …’ command, let it run until you are ready to profile it, then use the ‘nsys start …’ and ‘nsys stop’ commands to run a collection. Note that you can run multiple start/stop commands back to back to collect data for the same running application.

I ran into this limitation too, two years later. I was going to try get some python deep learning code to launch the nsys profiler and attach it to itself. The code I want to profile is launched by a distributed computing framework on some random cluster node. I have easy control of the code being profiled, but changing the larger framework will require coordination and approval of a bunch of people.