Nsight-systems gives segmentation fault inside docker, need the one for L4T R36.2

Hi,

On a Jetpack 6 (R36.3) installed Jetson AGX Orin, I am running a container of the following image from NGC:
https://catalog.ngc.nvidia.com/orgs/nvidia/containers/l4t-ml
nvcr.io/nvidia/l4t-ml:r36.2.0-py3

The docker image doesn’t contain nsight-systems, so I exposed the one installed on the host system with the --volume argument of docker. The following is my docker run setting:
–runtime nvidia --net host -it --privileged --cap-add=ALL --ulimit rtprio=99 --tmpfs /tmpfs -v /home/nvidia/ssd/shared_data:/root/shared -e DISPLAY=$DISPLAY -v /tmp/.X11-unix/:/tmp/.X11-unix --volume=“$HOME/.Xauthority:/root/.Xauthority:rw” -v /opt/nvidia/nsight-systems:/opt/nvidia/nsight-systems

After this, running the nsys profile produces segmentation fault for any program inside the docker container. For example:
/opt/nvidia/nsight-systems/2024.2.2/target-linux-tegra-armv8/nsys profile ls
results segfault.

I think this is caused by the mismatch of L4T versions of the docker image and the host (R36.3 vs R36.2). It works fine when nsys is used outside of docker. Please let me know how I can get the nsight-systems CLI for R36.2, or a way to fix this segmentation fault.

Hi,

Do you run the container with rootless mode or not?
It mean you launch the container with sudo docker ... or docker ...?

Since profiling usually requires root authority.

Thanks.

I run it with “sudo docker run …” It is also the privileged root user executing the nsys inside the docker.

Hi,

Could you try to profile an app within the r36.3? For example, l4t-jetpack:r36.3

If this solves the issue, please use a r36.3 container instead.
Thanks.

I need to use the NVIDIA L4T ML container specifically as I need the libraries installed there. Please let me know a better solution, I don’t want to switch containers.

Hi,

How about to rebuild a l4t-ml container for r36.3?
Please find the Dockerfile and corresponding script below:

Thanks.

1 Like

I couldn’t figure out the instructions on how to build for r36.3 in the repo you sent but I utilized the instructions to install numba from there and carried out the rest of it myself on top of l4t-jetpack:r36.3 container. It works now, thanks!

Good to know it works.
Thanks for the update.