Nsight unresolved inclusion with synched projects

Dear all,

I recently started using Nsight after reading about its potential and the cool stuff which can be done with it. I have managed to create a synched project which is on the Jetson tx1, but in the IDE, I get unresolved inclusion problem. I have tried to include the libraries by copying them over to the host computer but the problem did not go away. Everything works when I compile its just the IDE does not know about the libraries. I tried to go to settings ‘path and symbols’ and ‘preprocessor include’ to setup but it does not work. Is there a way to somehow link remote libraries so the IDE knows about them?

Also, nsight created a folder called RemoteSystemsTempFiles which contains some of the libraries, ( i have no idea why it does not contain all libraries needed for the project ) and those libraries are recognized but I don’t know what to do with the rest.

Sorry for the noobish question, I looked online for a very long time but did not find an answer to this specific problem.

Thank you very much for reading,



I think you talked about Nsight Eclipse Edition instead of Nsight Visual Studio Edition, right ?

If you want to link remote libraries, you need set in Target Systems.
(Right click the project->Properties->Build->Target Systems->Manage the remote connection)

Then you can go to Settings(this option just above the “Target Systems”), to specify the NVCC Compiler->Includes or NVCC linker->Libraries

Let me know if this helps.

Thanks !

HI Veraj,

Sorry, just realized that I am in the wrong topic, I have the eclipse edition, not the visual studio.

I have tried the steps you mentioned but no luck. The project compiles fine and I can run it on the remote system, but I get unresolved inclusion errors on the host system. I do not have any problems, running or compiling the code. The problem is only the editing on the host. As I said it recognises some of the libraries which were somehow synched in the RemoteSystemTempFiles, but some libraries are missing and I have no idea why.

Thank you for helping!

Hi, liquidmind

You mean even the code can compile successfully, it still show some errors in editor, right ?

I have met this problem before actually.

Running the C++ indexer on the project will resolve the errors in the editor.

Can you try the following and refresh the project?

Right click on the project->Index-> Resolve unresolved includes
Right click on the project->Index-> Rebuild