Nsight won't capture D3D if I link to WindowsSDK

June2010 SDK is very old and effectively deprecated. There is also KB2670838 that causes a crashes in PIX if I link to June 2010 SDK.

In my test application, if I link to June2010 libraries, I can capture with Nsight. If I link the same app to official WinSDK libraries, Nsight capture ends immediately (connect, then disconnect) with no opportunity to show the UI.

Why can’t I use the official WindowsSDK libraries with Nsight? How are Win8 developers getting around this?

Hi TimRS,

Nsight should support Windows SDK now, could you please show more detail information then we can identify what happens:

  • nsight version
  • your OS version, GPU version, driver version
  • could you share us a simple project which can repro this issue? Have source code can help investigate quickly.

Actually, we have some local samples which use Windows SDK, they run with nsight smoothly.


Win7 With Sp1/platform update
Quadro K4000 334.95

I also tried with my 660GTX at home, same result.

I can package up my test app for you in a bit. I’ll post here again.