NvAPI_DRS_EnumAvailableSettingIds Function isn't found

Hi,

I’ve been able to access all the other NVIDIA Functions I’ve tried, but I cannot access NvAPI_DRS_EnumAvailableSettingIds at all. I’ve checked in Ghidra and in Dumpbin and both say the function is living at address 0xF020614A, but it is the one function I cannot map. All other functions work and can be used correctly.

I’m using C# and PInvoke to access the C functions. NvId_DRS_EnumAvailableSettingValues works at address 0x2EC39F90, NvId_DRS_LoadSettings at 0x375DBD6B and all the other DRS functions work too. It’s ONLY NvAPI_DRS_EnumAvailableSettingIds that doesn’t work.

Does anyone have any ideas what it could be?

I tried checking to see if the function address changed in R510, but its the same. I though maybe there was a problem in my code but I’m using exactly the same function mapping code that worked on all the other NVAPI functions.

I’m using a DLL entrypoint of “nvapi_QueryInterface”. Is that correct? Then the DLL is initialised, and then I can access every function after that - except NvAPI_DRS_EnumAvailableSettingIds …

Thanks
Terry