Nvbuf-memory-type on gst-dsexample

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson)
• DeepStream Version:6.0
• JetPack Version (valid for Jetson only):4.6
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

I want to enable blur-objects in gst-dsexample plugin on jetson, but I found folling code:

    if(!dsexample->is_integrated) {
      if (dsexample->blur_objects) {
        if (!(surface->memType == NVBUF_MEM_CUDA_UNIFIED || surface->memType == NVBUF_MEM_CUDA_PINNED)){
          GST_ELEMENT_ERROR (dsexample, STREAM, FAILED,
              ("%s:need NVBUF_MEM_CUDA_UNIFIED or NVBUF_MEM_CUDA_PINNED memory for opencv blurring",__func__), (NULL));
          return GST_FLOW_ERROR;
        }
      }
    }

I want to know if it meas this function only support NVBUF_MEM_CUDA_UNIFIED and NVBUF_MEM_CUDA_PINNED?
But jetson not support NVBUF_MEM_CUDA_UNIFIED and NVBUF_MEM_CUDA_PINNED parameter

/**
 * Specifies memory types for \ref NvBufSurface.
 */
typedef enum
{
  /** Specifies the default memory type, i.e. \ref NVBUF_MEM_CUDA_DEVICE
   for dGPU, \ref NVBUF_MEM_SURFACE_ARRAY for Jetson. Use \ref NVBUF_MEM_DEFAULT
   to allocate whichever type of memory is appropriate for the platform. */
  NVBUF_MEM_DEFAULT,
  /** Specifies CUDA Host memory type. */
  NVBUF_MEM_CUDA_PINNED,
  /** Specifies CUDA Device memory type. */
  NVBUF_MEM_CUDA_DEVICE,
  /** Specifies CUDA Unified memory type. */
  NVBUF_MEM_CUDA_UNIFIED,
  /** Specifies NVRM Surface Array type. Valid only for Jetson. */
  NVBUF_MEM_SURFACE_ARRAY,
  /** Specifies NVRM Handle type. Valid only for Jetson. */
  NVBUF_MEM_HANDLE,
  /** Specifies memory allocated by malloc(). */
  NVBUF_MEM_SYSTEM,
} NvBufSurfaceMemType;

So, my question is I want to enable blur-objects on jetson, how can I setting?
Thank you very much.

is_integrated is a flag for Jetson (==1) or dGPG (==0), so the code inside this condition is for dGPU only, it’s not applicable for Jetson.

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one.
Thanks

There is sample of how to get data from NVBUF_MEM_SURFACE_ARRAY type memory. deepstream_tao_apps/gazeinfer.cpp at master · NVIDIA-AI-IOT/deepstream_tao_apps (github.com)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.